Curly apostrophes problem

User avatar
mtrahan
Posts: 81
Joined: Sun Feb 10, 2013 2:21 pm
Platform: Mac + Windows
Location: Montreal
Contact:

Sat Dec 08, 2018 1:18 pm Post

Hello folks,

For some reason, I just got back to a project after a couple months away, and I can't seem to be able to get curly apostrophes in this project. I have the curly quotes options active in the preferences, and it's working fine in all my other projects except this one. Is there anything else I am missing?

And what's the most puzzling is that curly apostrophes were working fine in this project until now. I've been working on this project for about two years and all apostrophes in it are curly except those written since this morning...

Please send help. :-)
English is not my first language.

User avatar
KB
Site Admin
Posts: 20488
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Mon Dec 10, 2018 11:37 am Post

Just to check - is it definitely not a font problem? That is, if you change the font to, say, Times New Roman, do apostrophes appear curly?

Otherwise, what happens if you turn off. page view (if you are using page view), restart the app, and then try? Do curly apostrophes work then?
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

User avatar
mtrahan
Posts: 81
Joined: Sun Feb 10, 2013 2:21 pm
Platform: Mac + Windows
Location: Montreal
Contact:

Tue Dec 11, 2018 2:12 am Post

It’s unfortunately not a font problem: I pretty much only used Georgia for the past decade.

I’m not 100% sure what you mean by "page view" (I’m using Scrivener in French)? I mostly use composition mode, but if by "page view" you mean like regular document view (as in not "outline view"), I just for example switched to outline and restarted Scrivener and it had no effect. Still no curly apostrophe in this project for some reason.

Thank you for the assistance.

KB wrote:Just to check - is it definitely not a font problem? That is, if you change the font to, say, Times New Roman, do apostrophes appear curly?

Otherwise, what happens if you turn off. page view (if you are using page view), restart the app, and then try? Do curly apostrophes work then?
English is not my first language.

Jo
JoRo
Posts: 490
Joined: Sat May 26, 2018 6:40 am
Platform: Mac

Tue Dec 11, 2018 8:23 am Post

1. I don't know the French term, but in the hope that it helps, the image below shows where page view can be found in the menu structure. You can turn it off or on using CMD SHIFT OPT P

Page View.jpg
Page View.jpg (199 KiB) Viewed 47 times


2. Are smart quotes turned on under: Edit > Substitutions > Smart Quotes (the option should have a tick next to it)?


3. Alternatively, you could type the quote mark you need:

Left single quotation mark ‘ => OPT ]

Right single quotation mark (and apostrophe) ’ => OPT SHIFT ]

Left double quotation mark “ => OPT [

Right double quotation mark ” => OPT SHIFT [


4. And to correct current issues, you can use:
Edit > Transformations > Convert Quotes to Smart Quotes

Slàinte mhòr.

User avatar
KB
Site Admin
Posts: 20488
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Tue Dec 11, 2018 11:18 am Post

Given that it is just happening on one project, could you please zip it up and email it to us at Mac.support AT literatureandlatte.com so that we can see if we can reproduce the problem?

Thanks and all the best,
Keith
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

User avatar
mtrahan
Posts: 81
Joined: Sun Feb 10, 2013 2:21 pm
Platform: Mac + Windows
Location: Montreal
Contact:

Tue Dec 11, 2018 2:02 pm Post

Problem solved: the "Edit > Substitutions > Smart Quotes" option was unchecked for some reason. My apologies for the confusion, I must have forgotten about this setting. When I meant that I had "curly quotes options active in the preferences", I meant in the general Preferences menu > Corrections > Use smart quotes in new project (or something similar—I got the french version). I couldn’t find any other option related to smart quotes when I posted.

Thank you all, and sorry for this silly situation.
English is not my first language.