Is there a way to remove the blank line that separates scrivenings (most importantly for compile)?

Ro
Rolta
Posts: 2
Joined: Sat Sep 15, 2018 8:02 am
Platform: Mac

Sat Sep 15, 2018 8:13 am Post

Hello everybody. I'm new to the world of Scrivener and I'm having problems with just this one issue. When I write, I find it best to divide everything up into beats—so one small unit of a scene at a time—and I've fallen in love with the way Scrivener allows you to organise everything. As I write each beat I make a new document, kind of the way people seem to divide scenes within a chapter. Having a blank line between scenes is excellent and correct, but having a blank line between beats is something I really want to avoid. This seems to be automatic in the compiler. Can anyone help me? I've fiddled around with the compiler but it's confusing. I've watched some videos too, so coming to this forum is my next attempt to find help!

I believe my setup functions fine in screenplay format—my beats in a screenplay are combined with no extra blank lines in compile. I just can't work it out with fiction/non-fiction!

Thanks in advance.

Online
User avatar
AmberV
Posts: 22347
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Santiago de Compostela, Galiza
Contact:

Sat Sep 15, 2018 11:10 am Post

There sure is a way to do this! I’m a fan of breaking scenes down into smaller chunks as well. I’ll still want scene breaks of course, but between those breaks I want my outline to be completely “invisible” to the output. I’m assuming you’re starting with the default Novel project template, and I’ll be working a premise that there are folders that designate chapters, and that you’d like to have scenes within those chapters, and beats within those scenes.

  1. The first thing we want to do is establish a new Type of document in the project. Use the Project ▸ Project Settings... menu command, and open the Section Types pane. As you can see there are already a number of useful types here, like chapters and scenes. Create a new one called “Beat”.
  2. We could leave it at that, but then we’d have to manually assign the “Beat” type to every single document in the binder as we wrote, and that would quickly become annoying. So let’s make it so this happens automatically, just like chapters and scenes already do. Click on the “Default Types by Structure” tab.
  3. Note how “Level 2 files and deeper” are going to automatically be assigned to the “Scene” Type? All we need to do is add another level, so click on that line, and then the + button to create another level. Use the Section Type dropdown menu to select the new “Beat” Type for “Level 3 files and deeper”.
  4. There is one other change we need to make here, the implications of which will become more clear in the following steps. We want to add a new level to “File groups”, because our scenes will basically become file groups with beat files nested beneath them. So select “All file groups”, click the + button twice, so that we now have a “Level 2 file groups and deeper” setting. This will specifically target file groups found nested below the “Chapter” level (level 1). Change that from “Section” to “Scene”. You could also just set all file groups to “Scene”, if you do not intend to use file groups for anything else. Click OK to save your settings.
  5. Now at this point, it may already be working the way you want, provided you’ve been nesting beats into scene files in the outline. But if you haven’t been doing that try doing so. Select a group of beats that are meant to be one scene together, and use the Documents ▸ New Folder from Selection command. We don’t really want a folder here, but that’s a convenient way to automatically group a bunch of stuff into a new container. Rename “New Folder” as you want to refer to this scene. Now right-click on the folder and select “Convert to File”.

    Going forward you don’t have to do this every time. A more natural way of outlining as you write would be to hit the Return key to create a new scene, and then Return again to create a beat, and ⌃⌘→ to nest the beat beneath the scene. Well, there are many ways of creating new things and nesting them—that is the one I prefer because I like the keyboard. Drag and drop works just as well, but I’m sure you get the idea.
  6. Now to set up the compiler. First lets make sure all of the above worked as expected. On the right hand side is your contents list, which also shows the Types. Here is what I get, when doing some simple adjustment to the Novel format as described:

    ImageChapters, Scenes and Beats by outline depth.
  7. We want to create a new Section Layout that formats text just like a scene would—only without the empty line in between them. So it will be easiest to start with the Layout that scenes use. In the preview column, locate where “Scene” is shown, and hover over the preview tile for a moment. You’ll see the name of the Layout it uses printed in the tooltip.
  8. Again I’ll assume fairly default settings, so starting from “Manuscript (Times)”, right-click on the Format in the left sidebar and duplicate and edit it.
  9. Since we want the beat to format text normally, we’ll use the “Section Text” Section Layout, discovered via the tooltip (of course if you’re using a different Format, the specifics might be different). Find it in the list of Layouts, click on it to select it, and then click + to duplicate it. I’ll call it “Text Chunk”, to indicate that it’s a chunk of text really, not a section per se.
  10. We don’t need to change anything about how the Layout itself works. Feel free to click through the tabs, but we aren’t dealing with separation here, just formatting. For that, click on the Separators pane. You should find the “Text Chunk” Layout already selected for you in the list.
  11. Disable the Use default separators checkbox at the top. Set Separator before sections to “Single Return”. The same goes for Separator between sections. In the Manuscript (Times) format, there is also a setting that inserts a break wherever you insert your own empty line in the editor. That can probably be left alone—if you insert your own empty line while writing, presumably you mean it.
  12. That should be all you need to do here, so click Save to create your new Format.
  13. The last thing to do is make sure “Beats” are assigned to this new “Text Chunk” Layout. Click the Assign Section Layouts... button below the preview pane. Select “Beat” in the left list, and then find “Text Chunk” in the preview tiles and click on it. Click OK to save your assignments.
  14. Try compiling, and see if it all works the way you want.

There are of course many other ways to approach this. If you’d rather not have scene breaks at all, then you could dispense with a lot of the above and just change how “Text Section” separators work directly rather than creating a whole new Type and setting up a new Layout for it and so on. Or maybe you’d rather use folders for scenes instead of file groups, that would only require a small modification to the Project Settings step. You could even have scenes and beats on the same level if you want. We used levels because that grants us automatic type assignment, but another approach is to just have a list of beats in a chapter and manually insert “scene break” files that are simply manually set to the Section Type of “Scene”. One could even create a document template for that. There is no right answer here, but hopefully the description that goes over that one particular answer is enough to go from if your answer is slightly different. :)
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

Ro
Rolta
Posts: 2
Joined: Sat Sep 15, 2018 8:02 am
Platform: Mac

Sun Sep 16, 2018 10:00 am Post

My word, thank you so much for this reply. I'm very grateful. I had a quick play around, but at the moment I'm using the short story template, so things are slightly adjusted and I made a mistake somewhere along the way. I'm sure I can work it out eventually though! I might try and master this tonight, so I'll post another reply to confirm if I have success.

But really, thank you. The detail in your reply is excellent. I'm a new convert to Scrivener and absolutely convinced by it—this was the only thing that was frustrating me.