[LH646] Learn Spelling Ignores Words With Apostrophes

Ru
RussWhaley
Posts: 46
Joined: Wed Sep 07, 2011 9:19 pm
Platform: Windows

Mon Aug 13, 2018 1:41 am Post

Windows 10 Home Version 1803 OS Build 17134.112
Scrivener Version: 2.9.0.8 Beta (273511) 32-bit - 01 Aug 2018

I am encountering this behavior when attempting to teach Scrivener words which contain apostrophes.

For example, John's.: If I have John and the spellcheck doesn't recognize it, I'll right-click and then click "Learn Spelling" and the red underline is cleared.

However, when I do the same with John's, the red underline does not clear, leading me to suspect there's something about the presence of the ' which is causing the learn-spell routine to fail.

I've tested this with several "apostrophied" words and have gotten the same result.

pc
pcgeekesq
Posts: 29
Joined: Tue May 23, 2017 7:44 pm
Platform: Windows

Mon Aug 13, 2018 7:34 pm Post

Oddly, "Ignore Spelling" does learn the apostrophes.

th
thePhilosoraptor
Posts: 434
Joined: Sat Feb 13, 2016 3:28 am
Platform: Windows

Tue Aug 14, 2018 1:38 am Post

Thanks. This has been filed.
Bryan Bender

Ru
RussWhaley
Posts: 46
Joined: Wed Sep 07, 2011 9:19 pm
Platform: Windows

Sun Oct 14, 2018 9:12 pm Post

Just an update - same issue is occurring in Beta 10. The rest of learn spelling is working perfectly, thanks for tuning it up!

Windows 10 Home Version 1803 OS Build 17134.228
Version: 2.9.0.10 Beta (331052) 32-bit - 28 Sep 2018

jj
jje
Posts: 69
Joined: Sun Jul 06, 2014 5:57 pm
Platform: Windows
Location: Sussex, UK

Mon Oct 15, 2018 8:29 am Post

The problem is that Scrivener doesn’t recognise the curly quote (i.e. the typographic apostrophe) as an single inverted comma. You can fix this by closing Scrivener, opening the word list, then searching and replacing (in Notepad or similar). Changing the code for a single comma works, but you have to do it each time you add a word, so it’s a temporary solution (at best).

Ru
RussWhaley
Posts: 46
Joined: Wed Sep 07, 2011 9:19 pm
Platform: Windows

Wed Oct 17, 2018 1:23 am Post

Hmmm... does Scrivener have the option of turning off "smart quotes" as Word does? That could be a workaround as well, and when I do final formatting &c in Word, it's very simple to put 'em all back.

Does the "ignore spelling" actually add the apostrophied word to the dictionary, or does it just stop alerting for that word?

jj
jje
Posts: 69
Joined: Sun Jul 06, 2014 5:57 pm
Platform: Windows
Location: Sussex, UK

Sat Oct 20, 2018 8:49 am Post

If you add a word that includes a typographic apostrophe, e.g. Darwin’s, it will be saved in your custom dictionary (wordlists.ini -- you will usually find it in \Users\[yourid]\AppData\Local\LiteratureAndLatte\Scrivener) as Darwin\xe8re's, and the spelling check then doesn't recognise it as equivalent to Darwin's (straight quote). But, if you have Darwin's (straight quote) in wordlists.ini, the spelling check recognises it as being the same as Darwin’s (tyopgraphic apostrophe).

So, one fix is to close Scrivener, open wordlists.ini using Notepad or a similar plain text editor. and search and replace, changing \xe8re into ' -- save and reopen Scrivener, and all is well, but that's a pain (obviously) since you have to keep closing and reopening Scrivener.

So, a slightly simpler alternative is that when you type the quote, Scrivener immediately replaces it with a typographic quote. but if you hit Ctrl-Z (undo) immediately, it will change back to a straight quote. Then type the s, then add the word to your dictionary. That saves you from having to switch back and forth from autoformatting straight and curly quotes as you go.

But, obviously, this is just a temporary fix to what is likely to be a temporary problem; I assume it will be changed in a future beta.