Focus in Composition Mode?

User avatar
mtrahan
Posts: 76
Joined: Sun Feb 10, 2013 2:21 pm
Platform: Mac + Windows
Location: Montreal
Contact:

Sun Aug 12, 2018 12:05 pm Post

Hello,

I have been using Scrivener 2 since 2011, and I just got a new computer so I'm finally trying Scrivener 3. I love it globally but I'm experiencing that is bothering me: whenever I switch to composition mode (full screen), the cursor disappears from the text (like if I clicked on something and the focus is now elsewhere).

Why is that? Can I change this?

It's very annoying because for example I press Cmd-Option-F to go into composition mode with keyboard shortcut, but then I have to manually click in the text if I want to start typing. I can't really understand. Focus should stay in the text area and I should be able to start typing right away, no?

Thanks for any help, and sorry if my description of the problem is unclear.
English is not my first language.

User avatar
auxbuss
Posts: 145
Joined: Mon Nov 30, 2015 9:50 pm
Platform: Mac
Contact:

Mon Aug 13, 2018 1:09 pm Post

I had an issue with focus in composition mode recently, although it was related to macOS tabs. So I can only make a suggestion.

Try going to Preferences/Behaviours/Composition Mode and unchecking all the options. (fyi: the top selection I have on that dialogue is Current Screen and the bottom Hide Dock.)

It definitely does work, per your expectation, so if my suggestion doesn't work – or lead to a fix – then I expect a mod will be along with other suggestions.
Image

User avatar
mtrahan
Posts: 76
Joined: Sun Feb 10, 2013 2:21 pm
Platform: Mac + Windows
Location: Montreal
Contact:

Thu Aug 16, 2018 10:43 am Post

Thank you very much for the help. Unfortunately, turning off all options in on that screen doesn't make any difference regarding this problem: whenever I enter Composition mode, my cursor is nowhere to be found so I lose where I was and have to manually click in the text to be able to interact with it.

I'm still hoping to find a solution as this seems like a rather odd problem.
English is not my first language.

User avatar
auxbuss
Posts: 145
Joined: Mon Nov 30, 2015 9:50 pm
Platform: Mac
Contact:

Thu Aug 16, 2018 11:17 am Post

How very frustrating!

It's probably worth trying this: Save your preferences as a preset then reset to the defaults. (On the off chance that the prefs have a glitch in them; possibly due to bringing them over from Scriv 2.)

Otherwise, I'd report this in the Bug Hunt forum where it might attract a L&L more quickly.
Image

User avatar
mtrahan
Posts: 76
Joined: Sun Feb 10, 2013 2:21 pm
Platform: Mac + Windows
Location: Montreal
Contact:

Thu Aug 16, 2018 12:32 pm Post

I’ll try it when I’m back home, but it sounds unlikely: Scrivener 2 has never been installed on this computer. It’s all fresh. :-)

Thanks again!
English is not my first language.