[LH3195] Unable to delete comments

User avatar
Pampurrs
Posts: 26
Joined: Mon Jun 25, 2018 1:05 am
Platform: Windows

Sat Jul 28, 2018 3:22 pm Post

I just discovered what may be a bug in this beta....

Whenever I delete a comment, either by clicking on the X in the corner or on the "-" up above, the comment disappears. But the minute I start typing again, anywhere in the document, the comment reappears, even if I save the project.

Oddly, if I close the project and reopen it, the comments are gone. I don't know if this is a bug, or by design, but I thought I should report it (If it hasn't been already).

Pam

User avatar
Pampurrs
Posts: 26
Joined: Mon Jun 25, 2018 1:05 am
Platform: Windows

Tue Jul 31, 2018 9:29 pm Post

Apparently, this was fixed in beta 7. It's no longer doing it.

Thanks

Pam

EDIT: I was premature in this report. The problem still exists on the new release.
Last edited by Pampurrs on Mon Aug 06, 2018 9:19 pm, edited 1 time in total.

Iv
IvyNelson
Posts: 6
Joined: Wed Dec 06, 2017 10:59 pm
Platform: Windows

Mon Aug 06, 2018 7:05 pm Post

I'm actually still having this issue and was going to come post a bug report about it when I saw yours. I've been trying to delete a comment and every few minutes I look and its back. So far it's just one of about 6 comments that I've deleted that keeps reappearing.

User avatar
Pampurrs
Posts: 26
Joined: Mon Jun 25, 2018 1:05 am
Platform: Windows

Mon Aug 06, 2018 9:19 pm Post

IvyNelson wrote:I'm actually still having this issue and was going to come post a bug report about it when I saw yours. I've been trying to delete a comment and every few minutes I look and its back. So far it's just one of about 6 comments that I've deleted that keeps reappearing.


It's still doing it on mine too. I was premature in reporting that it had been corrected in the latest beta. This looks like a bug to me.

Pam

th
thePhilosoraptor
Posts: 511
Joined: Sat Feb 13, 2016 3:28 am
Platform: Windows

Tue Aug 07, 2018 2:14 am Post

Hello! Yes, others have reported this as well and we are trying to get to the bottom of it. Does this occur for you frequently or only occasionally?
Bryan Bender

User avatar
tiho_d
Posts: 390
Joined: Tue Sep 13, 2011 1:14 pm
Platform: Linux + Windows

Tue Aug 07, 2018 6:42 am Post

Hi guys, can you please upload your project as an archive only with the document showing the issue and a note about the comment which fails deleting. Some instructions about the steps you do are also welcome. We still cannot reproduce this bug and hopefully your project will help us. Many thanks for helping us make Scrivener v3 better.

User avatar
Pampurrs
Posts: 26
Joined: Mon Jun 25, 2018 1:05 am
Platform: Windows

Tue Aug 07, 2018 1:21 pm Post

tiho_d wrote:Hi guys, can you please upload your project as an archive only with the document showing the issue and a note about the comment which fails deleting. Some instructions about the steps you do are also welcome. We still cannot reproduce this bug and hopefully your project will help us. Many thanks for helping us make Scrivener v3 better.



It appears to be only happening in a project that I converted from Scrivener 1.9 to the 3.0 Beta, and only with notes that were created prior to the conversion. If I create new notes in the converted project, the problem does not exist, nor does it exist in a document created in 3.0 Beta.

I hope this helps.

Pam

Iv
IvyNelson
Posts: 6
Joined: Wed Dec 06, 2017 10:59 pm
Platform: Windows

Wed Aug 08, 2018 3:38 am Post

tiho_d wrote:Hi guys, can you please upload your project as an archive only with the document showing the issue and a note about the comment which fails deleting. Some instructions about the steps you do are also welcome. We still cannot reproduce this bug and hopefully your project will help us. Many thanks for helping us make Scrivener v3 better.


I'm not sure how to do that but I will gladly do so if you tel lme how! It's still doing it for me and had done it with more comments than just the one I mentioned above.

User avatar
tiho_d
Posts: 390
Joined: Tue Sep 13, 2011 1:14 pm
Platform: Linux + Windows

Sun Aug 12, 2018 1:10 pm Post

Hi All, to archive your project easiest would be to use File > Back Up > Back Up To and selecting the ZIP archive option. Please, upload the generated ZIP archive within this forum thread. Many thanks for your help, guys!

Iv
IvyNelson
Posts: 6
Joined: Wed Dec 06, 2017 10:59 pm
Platform: Windows

Sun Aug 12, 2018 9:06 pm Post

[quote="tiho_d"]Hi All, to archive your project easiest would be to use File > Back Up > Back Up To and selecting the ZIP archive option. Please, upload the generated ZIP archive within this forum thread. Many thanks for your help, guys![/quote

I just tried and it says it's too large a document. It is a 100,000 word project so... is there another way to get it to you?

User avatar
tiho_d
Posts: 390
Joined: Tue Sep 13, 2011 1:14 pm
Platform: Linux + Windows

Thu Aug 16, 2018 9:46 am Post

Hi IvyNelson, you can share the archived project via Dropbox, Google Drive or any other file sharing service you feel comfortable using. Unfortunately the forum has a limitation on attachment file sizes.

User avatar
MimeticMouton
Posts: 8679
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Thu Aug 16, 2018 4:00 pm Post

It's probably unnecessary to see the entire project; you might try to use Save As to create a copy, then trim down the copy to just a few of the documents that demonstrate the problem. So long as the reduced sample still reproduces the issue, that's all we need.

You can also upload and send the link to win3beta@literatureandlatte.com rather than posting on the forum if you prefer to keep the project private. Please just reference this forum thread in the email. Thanks!
Jennifer Hughes
(MM for short)

User avatar
Pampurrs
Posts: 26
Joined: Mon Jun 25, 2018 1:05 am
Platform: Windows

Thu Aug 16, 2018 9:28 pm Post

Jennifer,

You may not have seen my earlier comment in which I had discovered that the problem only exists with comments that were entered in projects created in version 1.9 and then saved as 3.0 projects. Comments entered after the project was converted and saved in 3.0 are no problem, only the ones that were carried over from 1.9.

Pam

User avatar
tiho_d
Posts: 390
Joined: Tue Sep 13, 2011 1:14 pm
Platform: Linux + Windows

Tue Aug 21, 2018 10:51 pm Post

Hi Pampurrs, I tested several upgraded projects with Inspector notes. Unfortunately I still cannot reproduce the issue. It would be great if some of you could upload a small project with one document showing the issue. Many Thanks!

To
TomGoodell
Posts: 87
Joined: Tue Nov 13, 2012 3:13 pm
Platform: Windows

Fri Aug 24, 2018 1:02 pm Post

I was having a similar issue and did some testing. The problem showed up in a project I imported from 1.9, I then reproduced it in a new Scriv 3 beta project. Here's what I did:

Created a new blank project
Created several files in the project and pasted text into them

File 1 test:
Select a paragraph and add a comment to it
Select another paragraph somewhere else and add a comment to it
Go back to the first paragraph and select the commented paragraph and the next two paragraphs
Extend the comment to all 3 paragraphs
Remove the comment
The comment is removed from the last two paragraphs it was added to, not the first paragraph
Delete the comment from the first paragraph; the comment disappears, but the text remains highlighted, and when I click to another file in the other editor and come back to the first one, the comment is back

File 2 test:
Selected several paragraphs and added a comment
Selected several other paragraphs and added a comment
Deleted first comment; highlighting was removed from all but first paragraph and comment disappeared
Clicked to another file in the right hand editor, then back to the left editor, the comment is back


File 3 test:
Selected a single word and added a comment
Selected a single word in another paragraph and added a comment
Deleted first comment; it was successfully deleted
Deleted second comment, it was successfully deleted

The comments that wouldn't delete persist after closing and opening the project.

Workaround: If you delete the paragraph that won't lose its comment, then Control-Shift-V to paste it back, it comes back with no comment, but the comment text at the end of the paragraph, which you can then delete.

I hope this is helpful. Let me know if you want me to upload the project.