Default paragraph style

Ka
Kadah
Posts: 2
Joined: Mon Sep 14, 2015 9:15 pm
Platform: Mac

Thu Jul 12, 2018 3:53 pm Post

I feel extremely frustrated. I created a couple of styles. I copied them between documents. Some parts or the text are in the "no indent" style. Some of them are in the "indent" style. When I write a paragraph with the "indent" style and press return the next paragraph is "no style". Why???? Do I have to set every paragrph's style manually? This is crazy. Why does scrivener change my paragraph style? What can I do to make it stop?

User avatar
AmberV
Posts: 22061
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Santiago de Compostela, Galiza
Contact:

Thu Jul 12, 2018 4:28 pm Post

I’d have a look at §15.6.1, Think Different, pg. 401 in the user manual. It sounds like you’re trying to use Scrivener like a conventional word processor, but it is not designed to be used that way. Its styles are meant for exceptional text, with body text left unstyled and freely modified by the compiler (styles by default pass through compile settings, which then raises problems if every single paragraph is styled).

After that, have a look at the options available in the compiler for automatic indent control. In all but the most unusual cases, one should not have to be bothering with whether or not their paragraph indents after a break or heading while writing. See page 619, but do note that many of our built-in templates and compile formats have sensible defaults—not that you’d see them if you style everything by hand though. ;)
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

A
A Really Nice Guy
Posts: 8
Joined: Tue Mar 15, 2016 11:58 pm
Platform: Mac

Mon Jul 16, 2018 9:38 pm Post

So I shouldn't style everything? Leave the bulk of the ms. unstyled?

User avatar
lunk
Posts: 2719
Joined: Wed Aug 21, 2013 4:24 pm
Platform: Mac + iOS
Location: Sweden 64° N

Mon Jul 16, 2018 9:44 pm Post

I never style anything. I have set up a ”no style” with my favourite font and size in Preferences, i.e. the way I want the text to look when I write. The compiled output is something completely different. :)
I am a user, writing non-fiction and science, using:
* Mac Scrivener 3 on a Macbook 12”, MacBook Pro 13”, and iMac 27”, all running the latest MacOS
* iOS Scrivener 1 on an iPhone 8, iPad Air 9.7”, and iPad Pro 12.9”, all running the latest iOS

User avatar
AmberV
Posts: 22061
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Santiago de Compostela, Galiza
Contact:

Tue Jul 17, 2018 4:16 pm Post

So I shouldn’t style everything? Leave the bulk of the ms. unstyled?


That’s the idea, yup! Use styles for those things that deviate from what you would consider to be body text, but for the rest just leave it be. The compiler is designed to optionally change the formatting of unstyled text en masse, and therein lies the problem. If you style everything, then the compiler cannot out of the box perform one of its primary functions: being able to take whatever font you prefer to write with and turn it into whatever font you need to submit/print/etc. You might select Manuscript Times, and get TNR everywhere but the body text, which remains Palatino, Helvetica or whatever you write with.

Now there is a way to override even body text—and some of the built-in compile Formats will try to do so (by looking for text styled “Body”)—by virtue of the same system that can take “Heading 1” text in Manuscript Times and make it TNR, but then turn it into Courier for Manuscript Courier. This is flexible, and if you really really want to you can use styles everywhere. It just means you’re likely going to need to edit compile formats in greater detail and be more aware of the many settings and such involved. You likely won’t get an easy default behaviour. Ultimately, why bother—the program isn’t designed to work that way, so you’re just making more work for yourself.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

User avatar
KB
Site Admin
Posts: 20118
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Wed Jul 18, 2018 8:22 pm Post

Also, if you do ever want to create a style so that when you hit return the text continues in that style, be sure to set the "Next Style" setting when creating or redefining the style.

All the best,
Keith
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."