Can ¥ (backslash) be used as a new line tag with MMD?

pt
ptmkenny
Posts: 22
Joined: Fri May 04, 2018 8:43 am
Platform: Mac + Windows

Wed May 16, 2018 8:19 am Post

I have written a document in Markdown and am compiling it (MultiMarkdown -> Web Page).

To insert a

Code: Select all

<br>
(new line) tag, in Markdown you can usually input two spaces after the end of the line. However, I don't like this because it's very hard to see if I have added spaces everywhere they are supposed to be.

MultiMarkdown has a command-line option to use the backslash (¥) character to do the same thing, like so:

Code: Select all

Put a <br> tag after this.¥


The documentation is here: http://fletcher.github.io/MultiMarkdown-5/escaped-newlines.html

Is there a way to have Scrivener make use of this option from within the UI somewhere, or do I have to set this up separately on my own?

User avatar
nontroppo
Posts: 964
Joined: Mon Mar 05, 2007 5:22 pm
Platform: Mac
Location: Airstrip One

Wed May 16, 2018 9:52 am Post

If you are going to be working in Markdown, it makes sense to "Show Invisibles" in Scrivener to visualise the structure much more clearly:

https://github.com/iandol/scrivomatic#e ... characters

You can customise the colour of the invisibles so they are not intrusive, but still visible. IMO this is more aesthetic than using \

Nevertheless you can get Scrivener to do this if you use a straight MMD compile and add your custom settings in the post-processing panel. Note than Pandoc supports backslash escaping by default, no need for a command-line option to enable it...

p.s. not sure why your backslash turned into a ¥ sign!?

pt
ptmkenny
Posts: 22
Joined: Fri May 04, 2018 8:43 am
Platform: Mac + Windows

Wed May 16, 2018 4:33 pm Post

Thanks, I already had invisible characters set to display, but I didn't realize you could change the color; that's helpful.

Unfortunately, the invisible marker for a space is just a tiny dot, and those are hard for me to see. It's also more difficult because when I work at night, I use f.lux to turn the screen on my Mac orange to reduce eyestrain, but this lowers the contrast significantly, making it even harder for me to see those dots.

It would be great if there was some way to visually distinguish a double space from a single space by changing the color or perhaps underlining it like some IDEs do for various programming languages.

I think I tried with Pandoc too and it didn't work, so perhaps that is because my backslash is a ¥ sign. That is caused by me using a Japanese keyboard with my Mac set up for a Japanese environment; in Japan, traditionally the currency symbol has been mapped to the backslash-- and not just mapped, it's actually used as a backslash in several cases, such as Windows file paths.

Of course, this can cause lots of problems when a software expects a "real" backslash and gets ¥ instead, so I'll dig into that and see if I can get it working. Thank you for pointing me in the right direction!

User avatar
AmberV
Posts: 21449
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Santiago de Compostela, Galiza
Contact:

Wed May 16, 2018 5:51 pm Post

MultiMarkdown version 6 supports this convention by default. If you have not already done so, you can install a copy of it on your Mac—Scrivener will switch to using that instead of its built-in copy.

The next update for Scrivener will also include the latest MMD6.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles