[LH2489] : Unable to Paste Formatted Text into Word

User avatar
AlexDotEXE
Posts: 1
Joined: Tue Apr 17, 2018 1:32 pm
Platform: Windows

Tue Apr 17, 2018 2:03 pm Post

(I hope this is the right place to put this; I debated putting it in the Bug Hunt (Windows) category, but I wasn't sure if that included the beta version, so here I am.)

Scrivener Beta Version: 2.9.0.4 Beta (149671) 64-bit
Windows Version: Windows 10 Home Edition, Version 1709, OS Build 16299.371
Bug: Unable to copy and paste formatted text from Scrivener 3 Beta to Microsoft Word 2016.

Exactly what it sounds like - I can't copy formatted text from Scrivener 3 into a Word document. For example, if I have,
"formatted text formatted text formatted text"
in size 12 Courier New font, what pastes into word is
"formatted text formatted text formatted text"
in size 11 Calibri font. I can copy and paste from other programs into Word just fine (including Scrivener 1), but with Scrivener 3, all the formatting is completely lost. It should also be noted that right clicking in the Word document reveals a lack of "Merge formatting" and "Keep source formatting" options in the menu - the only option is "Keep text only". (And yes, I checked to make sure I had those options enabled in Word's options.)

Some people online had this problem, only with all text from any program losing the formatting when pasted to Word, and most of them traced the problem back to Skype Click-to-Call (which I do not have), while others traced it back to their VPN program (I had Bitdefender VPN, which I uninstalled to see if it fixed it. It didn't). This leads me to think that it may be a conflicting program, but I'm posting it here just in case a) it is a bug, and/or b) anyone has any ideas to remedy this.

I'm going to try uninstalling Bitdefender Total Security 2018 once I get home to see if that has any effect, and I'll post the results in a reply then.

EDIT: Uninstalling Bitdefender did not fix it. I thought it might, since people had traced it back to their VPN, and Bitdefender had a VPN component, but nope - this appears to be a bug with Scrivener.
Last edited by AlexDotEXE on Wed Apr 18, 2018 1:38 pm, edited 1 time in total.

th
thePhilosoraptor
Posts: 434
Joined: Sat Feb 13, 2016 3:28 am
Platform: Windows

Tue Apr 17, 2018 5:43 pm Post

Thank you! This was the correct place to post this, and the bug has been filed.
Bryan Bender