Can I Turn Off The Automatic Capitalization?

dr
driver49
Posts: 38
Joined: Fri Dec 05, 2014 4:30 pm
Platform: Mac

Wed Feb 04, 2015 12:44 pm Post

Everytime I type a period (.) in Scrivener, Scrivener wants to make the next character a capital letter.

I don't ALWAYS want a capital letter after every period.... know why I mean? If this was Scrivener, the "k" in know would have been "K."

And if I don't want that next character capitalized, I have to highlight the character(s) and then drill down into the menus to find the "convert to lower case" command.

Please tell me that there is an option in Preferences that turns this "feature" off.

Thanks,

--PS

r6
r6d2
Posts: 731
Joined: Fri Aug 23, 2013 4:50 pm
Platform: Mac + Windows

Wed Feb 04, 2015 2:19 pm Post

driver49 wrote:Please tell me that there is an option in Preferences that turns this "feature" off.

There is indeed. Go to Preferences/ Corrections/ Auto-Capitalization and uncheck Fix capitalization of sentences.

Hope this helps!
r6d2

Beware of realism when writing. Avoid the usual zoo inhabitants. Summon the unicorns and the tritons, and give them reality!
--Julio Cortázar

dr
driver49
Posts: 38
Joined: Fri Dec 05, 2014 4:30 pm
Platform: Mac

Fri Feb 06, 2015 4:54 am Post

Found it. Thanks.

--P

re
retrojim
Posts: 1
Joined: Fri Mar 06, 2015 12:18 am
Platform: Mac

Fri Mar 06, 2015 12:22 am Post

It's good you can turn it off in preferences, but I suspect that the main problem is that the OP was incorrectly using an ellipsis. When I tried it in Scrivener I couldn't get it to auto capitalize if I typed a proper ellipsis...like this. Or even... like this with an extra space.

But if I typed four dots and a space like in the original post.... It capitalized the next word.

Just FYI.

Br
Briar Kit
Posts: 1788
Joined: Thu Apr 04, 2013 9:04 am
Platform: Mac

Fri Mar 06, 2015 7:00 am Post

An ellipsis is made up of three dots. It has its own typographic character.

On a Mac, in English, type…
ALT SEMICOLON

On an iPad using UK English…
Toggle to the number keypad, then flick the full stop key upwards.

To undo an individual instance of automatic capitalization on a Mac, just hit CMD Z. No need to convert the character through the menu system.

Appendix B of the Scrivener manual (available in Scrivener itself from HELP > SCRIVENER MANUAL) details Preference options.
Account closed January 2017

User avatar
SarsenLintel
Posts: 455
Joined: Thu Jan 10, 2013 4:46 pm
Platform: Mac + iOS

Fri Mar 06, 2015 3:29 pm Post

retrojim wrote:It's good you can turn it off in preferences, but I suspect that the main problem is that the OP was incorrectly using an ellipsis. When I tried it in Scrivener I couldn't get it to auto capitalize if I typed a proper ellipsis...like this. Or even... like this with an extra space.

But if I typed four dots and a space like in the original post.... It capitalized the next word.

Just FYI.


Also (IIRC) if you have the option to convert three dots into an ellipsis turned OFF... then Scrivener just views them as periods and so it capitalizes the next word if autocapitalization is ON.

Ne
NeoEclipse
Posts: 1
Joined: Sun Jul 08, 2018 2:44 pm
Platform: Mac

Sun Jul 08, 2018 2:46 pm Post

I'm having the same problem, but when I go to preferences, automatic capitalization is already unchecked. Problem is still not fixed and this makes writing dialogue really annoying.

Jo
JoRo
Posts: 453
Joined: Sat May 26, 2018 6:40 am
Platform: Mac

Sun Jul 08, 2018 4:21 pm Post

Various settings to check and toggle on / off, depending on individual needs...

System Preferences > Keyboard > Text > Correct spelling automatically (and Capitalise words automatically, if needed)

And Scrivener > Preferences > Corrections > Correct spelling errors as you type

And, for each project, Edit > Spelling and Grammar > Check Spelling While Typing

And, optionally, Scrivener > Preferences > Corrections > Fix capitalisation of sentences

dr
drmajorbob
Posts: 190
Joined: Sun Jul 01, 2012 1:38 am
Platform: Mac

Sun Sep 16, 2018 9:09 pm Post

Type the next word, let Scrivener capitalize it, and push Undo (⌘z).