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Part 1

Getting Started



Chapter 1

About This Manual

Scapple has been designed to be a very simple program to learn and use. This user manual
is provided to you as a complete reference of the software. We hope that nobody feels the
need to read this manual cover to cover to use the software. Of course, we’d be delighted
if you are inclined to do so, but most people want to get down to business with a new
program, and the best way you’ll find for doing that is in the Help » QuickStart Guide
menu command. This brief two-page cheat-sheet has everything you need to know to
get started and become proficient at using Scapple. For those (hopefully rare occasions)
when a more detailed look into how the program works is required, this manual should
suffice.

This manual has been written using Scrivener' and is available from the Help menu,
under “Scapple Manual”. You should also find two copies which have been specially for-
matted to be printed on either US Letter or A4 standard printer paper from our website?.

Annotating the PDF: If you wish to make notes and annotate the PDF using soft-
ware such as Adobe Reader, it is recommended you download a separate copy, or
locate the PDF in the Scapple installation and drag a copy out for your own personal
use. When Scapple updates, it will very likely overwrite the existing PDF in the
installation (often with revisions to the text), which will destroy any of your notes.

Thttp:/ /www.literatureandlatte.com/scrivener.php
Zhttp:/ /www.literatureandlatte.com/support.php
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1.1  Terms and Conventions

Whenever the documentation refers to an action that you must take, the visible name for
that action will be formatted like so. Button labels, menu items, and keyboard shortcuts

will all be displayed in this fashion.

Menus will be displayed in a hierarchy using the “» ” character to separate top-level,
sub-menu, and commands. Example: To apply the “Blue Bubble” note style to a selection
of notes, invoke the Format » Note Style » Apply Note Style » Blue Bubble command.

Keyboard shortcuts will use the following symbols:

< &: the Command key, or the Apple key, is the one located directly to the left and
right of your spacebar.

< : the Option key is also labelled the Alt key on some keyboards, depending on
which country you purchased your Mac from. Some laptops only have one Option
key on the left side.

& ~: Control is usually located to the left and right of the Option keys on their
respective side. Some laptops only have one Control key between the Option key
and the Fn key on the left side.

< ©r: the Shift keys are rarely used by themselves in shortcuts but are often used in
combination with other modifier keys.

Using Keyboard Shortcuts When a keyboard shortcut requires a combination of modi-
fier keys, they will be printed together. Example: \0881 (which matches View » Show
Inspector) means you should hold down both of these modifier keys together and
then tap the | key on your keyboard. Some shortcuts in Scapple do not require any
keyboard modifiers at all. The Z key, for example, will enable the QuickZoom fea-
ture while it is depressed. Naturally, these shortcuts cannot be used when editing a
note, as the ‘Z’ key all by itself will type in that letter.

Contextual Menus On a Mac, these are accessed in two different fashions. If you are
using a mouse that has more than one button, click with the right mouse button
(or the left button, if using a left-handed mouse). Additionally, most of the Apple-
branded trackpads and mice have the ability to program surface areas of the device
to access the contextual menu. If you do not have a mouse or trackpad that is
capable of supporting more than one type of click, then holding down the Control
key and clicking will always work.
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1.2 Finding Things

Since this PDF has been birthed within the age of digital documentation, and has yet to
make its way to print form, a proper index has never been compiled for it. Despite this,
in practice you should have little difficulty in locating the topic you are interested in.
Modern PDF reader software features excellent searching capabilities; most things can
be discovered merely by searching for the proper names of things—as labelled in menus,
buttons or dialogue boxes—in the PDF.

Alternatively, the appendices have been designed as a sort of topical index. If you
have a question about a particular menu command, for instance, you can find it in the
appendix, Menus and Keyboard Shortcuts (Appendix B). Often, if the feature merits it,
there will be a cross-reference to a more thorough description of the feature earlier in the
text. When all else fails, a detailed table of contents has been provided at the beginning
of the document.



Chapter 2

What is Scapple?

scapple /skap'l/vt. to work or shape... roughly, without smoothing to a
finish.
—The Chambers Dictionary, 12" Edition

Scapple is an easy-to-use tool for getting ideas down as quickly as possible and making
connections between them. It’s the software equivalent of taking a large piece of paper
and writing your thoughts and ideas all over it, in no particular order, perhaps clustering
related notes and drawing lines and arrows between them as connections become appar-
ent.
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Figure 2.1: Ideas scrawled on paper

We don’t claim that there’s anything new or original about this process, of
course—there are whole books dedicated to similar planning techniques, such as Writ-
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Figure 2.2: Ideas scrawled in Scapple

ing the Natural Way by Gabriele Rico, and if you’ve ever worked in any sort of office
environment, you’ve probably been forced to endure a “brainstorming” session in front
of a whiteboard. But what’s oppressive when your boss is manically wielding a marker
pen can be liberating and productive when you are thinking about your own projects.

The idea behind Scapple was to take this process and incorporate it into a simple and
lightweight application: something no more difficult to use than pen and paper, but
which confers certain advantages that only computers can provide; advantages such as
the following:

< You never run out of paper, because the Scapple document expands to fit as many
notes as you want to create.

4 You can move notes around and make room for new ideas and connections.
< It’s easy to delete, edit and resize notes.

¢ You don’t have to retype everything into another format when you are done.

There is a veritable panoply of mind-mapping software out there, but what’s different
about Scapple is that it doesn’t force you to make connections; nor does it expect you
to start with one central idea and branch everything else off that. Instead, you are free



to write anywhere on the virtual paper. Individual notes can be as long or short as you
like. Its freeform approach gets out of your way so that you can focus on getting all of
your ideas down, moving them around, and discovering and making connections as you
go along.

It’s also so simple to use, we hope, that once you’ve read the two-page QuickStart
Guide (available from the Help menu), you’ll know everything you need. And even
if you don’t read a word of the QuickStart Guide, the two-sentence instructions that
appear when you create a new blank document should be more than sufficient to get
started: “Double-click anywhere to create a note. Drag notes onto one another to make
connections.”



Chapter 3

Registration and Updates

If you purchased Scapple from the Mac App Store, you can safely skip this section, as
it pertains to the registration and maintenance of the version of Scapple we sell through
our own site. Installation, activation and application updates will be handled for you by
the Mac App Store application.

3.1 Installation

1. Download Scapple from the Literature & Latte website. There is no difference
between the trial version and the registered version—you turn the trial version into
the regular version by purchasing a serial number and using it to activate the trial
version.

2. When the Scapple DMG (disk image) file finishes downloading, double-click on it
in the Finder (if it hasn’t opened for you automatically), and drag the Scapple icon
into your Applications folder.

Important: Scapple will not be correctly installed on your system if you drag the
icon directly from the DMG to the Dock—it must be dragged onto your hard disk
first.

3. To add Scapple to your Dock, drag it there from the Applications folder, or right-
click on its icon in the Dock after it has been launched, and select Options » Keep
in Dock from the contextual menu.

4. Once you have installed Scapple, you should eject the DMG from your computer
by clicking on the eject icon next to the Scapple volume in the Finder.

Note that if you attempt to run Scapple from a non-standard location—such as directly
from the DMG—you will see a warning message which will offer to install Scapple to the
Applications directory for you. This can be dismissed if you have intentionally installed
it to a non-standard location.
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3.2 Registration

You can try out all of the features of Scapple for 30 non-consecutive days without having
to pay or register. During that period, Scapple will be fully-functional. After 30 days of
use, you will no longer be able to access Scapple unless you register.

3.2.1 Purchasing Scapple

During the trial period, whenever you launch Scapple, you will be reminded of how
many trial days you have left and given the option of buying and registering. Clicking
on the “Buy Online” button will take you to the Literature & Latte online store, where
you can purchase a licence for Scapple. You can also visit the online store at any time by
selecting “Purchase Scapple. ..” from the Help menu.

When you buy a licence, you will be emailed your unique serial number, which will
have the following format:

SCAPPLEXXX-XXXX-XXXX-XXXX-XXXX-XXXX

Make sure you hold on to this serial number, along with the exact name under which
you registered Scapple (the “Serial Number Name”), as you will need both to register
Scapple again in the future. (Remember that you may need to re-register at a later date—
for instance when installing Scapple on a new system, or re-installing after wiping your
hard drive for some reason—so it is important to store this information safely.)

b

If you have lost your serial number, clicking on “Retrieve Lost Serial...” in the reg-
istration window will take you to our vendor’s self-service support site, where you can
request to have the information re-sent to you. If you do not have the necessary informa-
tion available to fill out that form, please contact us via our support e-mail address’, and

we will be happy to look up the information for you.

3.2.2 Registering Scapple

After purchasing a licence and receiving your unique serial number, you can register Scap-
ple by clicking on the “Enter License...” button in the “Scapple is unregistered!” box
that appears whenever you launch Scapple. Alternatively, you can choose “Register. ..”
from the application (Scapple) menu.

In the “Serial Number Name” box of the registration window, enter the exact name
under which you registered Scapple. Enter your unique serial number in the “Serial
Number” box, then click the “Register” button. You must make sure that both the user
name and serial number are exactly as they appear in the registration email you received,
or registration will fail.

Imailto:sales@literatureandlatte.com
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If you receive a message stating that the name or serial number is invalid:

< Check and make sure they are in the right order. The name of the software owner
should be in the top field, and the serial number in the second field.

< Try using Copy and Paste to transfer the information from the email to this form
and make sure that when you select the text in the email, the selection range does
not extend beyond the first or last letter or number in the name or serial number.

< If all else fails, quit and relaunch Scapple. This can sometimes clear out pesky
gremlins in registration procedures.

After clicking the “Register” button, Scapple will authenticate your copy over the in-
ternet. No personal information is relayed during this process. If for some reason the
internet is not available, you will receive a warning message with instructions on how to
activate the software manually. A URL will be provided which you can use on another
machine to access the activation code you’ll need to complete the registration process on
the original computer. Scapple will continue to work in the interim—you will just see a
nag message each time you launch Scapple until activation has been completed success-
fully.

Once Scapple has been registered, you can begin using it. There will no longer be a
time limit on its use, and you will no longer see the trial nag box at startup.

3.3 Application Updates

The second time you ever run Scapple, you will be presented with a panel which asks
whether or not Scapple should automatically check for updates. (To use this feature, you
must have a connection to the internet.)

If you click “Check Automatically”, then once a day when you launch Scapple, if your
computer is connected to the internet, Scapple will do a quick check to see if there is a
newer version available and will prompt you to update if one is found. (It is strongly
recommended that you always update to the newest version available.)

Choosing “Don’t Check” will disable automatic checks, in which case you will want
to select “Check for Updates...” in the application (Scapple) menu from time to time to
check for updates manually.

You can change your mind later by setting this option in the application preferences
(Appendix A). You can also adjust the frequency of the automatic checks in the prefer-
ences.

When a check finds available updates, a window will appear outlining the details of
the update. It is recommended that you take a quick look through the update notes, as
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occasionally certain changes in operation may be implemented. You can view the full list
at any time by following the link on the product page on our website.

To update the application when an update has been found, click the “Install Update”
button. Scapple will then download and install the latest version of the program for you.
When the download and installation is complete, you will be presented with a button to
restart the program. Click this, and after Scapple restarts it will be up to date.

Software vs. Your Work: The advent of mobile operating systems for tablets and
smart phones has unfortunately blurred the line between what a program is and what
your data is. On many of these devices, deleting or re-installing an application can
destroy your work.

Standard operating systems won’t work that way. Like all programs on your com-
puter, Scapple saves your work into files (or documents). There is absolutely no
connection between the software and your hard work. Upgrading versions, register-
ing your trial, switching to a beta build or even deleting the application entirely will
have no impact on the files you created with Scapple (save that you of course will not
be able to open them so long as Scapple is not installed; your work will be accessible
once the software is available again).




Chapter 4

Learning the Ropes

There aren’t really any difficult concepts to get your head around in Scapple—the most
difficult part of using Scapple should be the ideas on which you are working. You organ-
ise those ideas using four main elements: notes, connections, background shapes and stacks.
We’ll look at each of those here.

4.1 Scapple’s Main Interface

Scapple’s interface has been designed to be as minimal as possible—for the most part, it’s
just you and your notes. The provided screenshot of the interface (2?) has been numbered
and explained, below.

1. The Scapple board, or canvas. “Scapple board” is the term used to describe a
Scapple document—all of the notes and their connections as laid out on the virtual
paper. The “canvas” is the background, or the virtual paper.

2. A note. A Scapple board can contain as many individual notes as you want. Notes
can be long or short, can wrap across multiple lines, and can be formatted with
borders, text colour, fill colour, bold, italics, underline and strikethrough.

3. A connecting line between notes. Connecting lines are always dotted lines unless
there is an arrow at either end (or at both ends).

4. An arrowed connecting line between notes. Since the line has an arrow, it is solid.
Arrows can be on either end, and can even be on both ends, as shown to the left of
#4 in the figure.

5. The inspector. This can be called up by selecting the View » Show Inspector menu
command (or by hitting \&1).

6. The footer bar. The number of notes is displayed in the centre of the footer bar. If
more than one note is selected, the number of selected notes is also displayed.

12
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Figure 4.1: The default Scapple window and features

Reset

7. The scale slider and scale “Reset” button. Move the slider to zoom in and out of
the Scapple board, and click “Reset” to reset the scale to the default. You can also
use the keyboard shortcuts Y& UpArrow and % DownArrow to zoom in and out
respectively, or Z by itself to show the entire canvas so long as the Z key is held
down.

8. A background shape around two notes. As with notes, shapes can be styled in
many ways. This shape has a drop-shadow, fill colour, square shape and a black
border.

9. A stack of notes. Stacks are vertical groups of notes that can be easily edited and
selected together as a list.

4.2 Notes

You can create and move notes anywhere on a Scapple board. Notes can be anything—
a single word used as a title using a large, bold font, or several paragraphs of detailed
description. There are no limits to how you arrange them—Scapple boards are entirely
freeform.
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4.2.1 Creating Nofes

To create a new note, do one of the following:

< Double-click anywhere on the background canvas area to create a new note at the
mouse point. By default, the new note will have the placeholder text “New Note”
selected, ready for you to type over it with your own text.

< If any notes are selected, you can hold down modifier keys while double-clicking
to create a new notes that are connected to the selected notes. Holding down the
Option () key will create a new note that is connected by an arrow pointing to
the new note; holding down the Command (#¢) key will create a new note that is
connected by a dashed line to the selected notes.

4 Use Notes » New Note ($2Return). If there are no notes selected, this will create a
new note in the view area. If there is a note selected, this will create a new note
directly underneath the selected note—in which case the menu item will appear as
“New Stacked Note” in the Notes menu (section 4.5).

4 You can also use one of the options in the Notes » New Connected Note sub-menu
to create a new note that is connected to the selected note (these options are only
available if one or more notes are selected). You can create a new note connected to
the selected note by a dotted line or by an arrow. The associated keyboard shortcuts
can also be used to create a new note connected by a dotted line above, below, to
the left or right of the selected note (such as ~ & LeftArrow to create a new note to
the left), or to create a new note connected by an arrow above, below or to the left
or right of the selected note (such as ~ gt LeftArrow to create an arrow pointing to
the new note to the left).

< To add a new note berween two connected notes, you can double-click on the con-
necting line (??). This will cause the connection between the two existing notes to
be removed, and new connections to be created between the existing notes and the
new note. If you make a mistake when doing this, simply use Undo to get rid of
the new note and reconnect the existing notes.

4.2.2 Selecting Notes

To select notes, do one of the following:

¢ Click on a note to select a single note.
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Figure 4.2: Double-click the connection line to create a new note between them

< To select multiple notes, click on each note in turn while holding down the Shift
or Command key. This also acts like a toggle, and can be used to remove a note
from a selection.

< Use the arrow keys to select or travel to notes around the board. Stacked notes will
prefer each other for selection, after that the program will do its best to select the
next note in the direction of the arrow key you pressed. Hold down the Shift key
to add the other notes to the existing selection, much like when extending a text
selection in an text editor.

< Perhaps the easiest way of selecting multiple notes is to use the marquee selection
tool (??). To do so, simply click anywhere on the board outside of a note and then
drag the mouse with the left button still held down. A rectangle will appear that
moves with the mouse, and as you drag to resize the rectangle, anything that is
enclosed by or touches the rectangle will be selected. Release the mouse button to
finish using the marquee selection tool.

Holding down the Option key while dragging will remove notes from the current
selection.

< If you wish to discard a selection, you can click anywhere on the board background
with the mouse, or use the Edit/Deselect (32D) menu command.

< To flip the selection state for the entire board, use Edit »- Invert Selection ({r88l). If
for instance a board has three notes, “A”, “B” and “C”, and “C” 1s selected, the result
of this command would have “A” and “B” selected.
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4.2.3 Editing Notes

To edit a note, do one of the following:

< Double-click into it.
< Select the note and hit the Escape key.

< Return can be used to start editing, but only if “Return creates new notes” is dis-
abled in the General Preferences (Appendix A) tab.

To finish editing a note, do one of the following:

< Hit the Escape key.
< Select another note or click elsewhere on the Scapple board.
< Hit the Enter! key.

< If “Return ends editing” is ticked in the General Preferences tab, hit the Return
key.

The Return and Enter keys only act the same if “Return ends editing” is ticked in the
Preferences (this is not ticked by default). Enter will always end editing, but Return will
by default start a new paragraph.

"Not to be confused with the Return key. On a full-sized keyboard, the Enter key will be beside
the numberpad, and the Return key beside the letter keys. On most laptop keyboards, Enter is used by
combining the Fn key and the Return key.
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4.2.4 Moving Notes
With the Mouse

Movement is typically done with the mouse, in a manner that will be familiar to anyone
who has dragged and dropped files from one location to another in Finder.

< To move a note, simply click on it, hold down the left mouse button, and drag it to
its new location, letting go of the button when you are satisfied with its position.

< To move several notes, first select all the notes that you wish to move (subsec-
tion 4.2.2). Then click on one of the selected notes, keep the mouse button held
down, and drag to move all selected notes.

< To move two connected notes together, there is no need to select them both. Just
click the connecting line that joins them, hold down the mouse button, and drag.

When moving notes so that they will end up partially or completely outside of the
board, the overall size of the board may be increased to fit them. For example if you
select five notes, and start the drag from the lower-right note, so that this note is the only
one visible at the top-left corner of the screen, the other notes will “push” the boundary
of the canvas up and to the left if necessary to make space for them.

As you drag closer to the edge of the view, Scapple will scroll in that direction for
you, while you are dragging, gradually increasing in speed the longer you hold down the
mouse button. This lets you position notes off-screen from where they started.

Long Distance Travel: Sometimes you need to move a note from one point of a large
canvas to another. You could zoom all the way out, drag it, and then zoom back in.
However an easier technique would be to use the QuickZoom feature (chapter 7).
First, select the notes and then hold down the Z key. Now drag them to the proper
location, and let go of both the Z key and the mouse button. The selected notes
should remain visible as QuickZoom focusses the view based on where your mouse
pointer is (which in this case will be where you dropped the notes). Your selection
will remain after doing so, making it easy to fine tune the positioning at full scale.

With the Keyboard

Sometimes small adjustments are easier to make with the arrow keys on the keyboard,
especially if you wish to make sure that the note does not stray from its original horizon-
tal or vertical positioning (or axis). By default the arrow keys will select notes around the
currently selected note, but if you tap the M shortcut, Movement Mode will be enabled
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(2?). Now the arrow keys will push the selected notes in the direction of that arrow by
a small amount. If you would like to increase how far it moves with each keypress, hold
down the Shift key in combination with the arrow keys. You can hold down the arrow
key instead of tapping to move longer distances.

Notes can be moved with the
keyboard, too!

ey

Figure 4.4: Movement mode is indicated by this icon, in the lower left corner of the status

bar.

4.2.5 Copying Notes

To copy notes, select the notes you wish to copy and then do one of the following:

< Drag the notes to location you wish the copies to appear and hold down the Option
key while releasing the mouse button. When the Option key is held down, you will
notice that the mouse pointer will have a “+” icon beside it, which indicates that
the note will be copied rather than moved.

< Select Edit » Copy (3£ C) then select Edit/Paste (38 V). When you select Paste from the
Edit menu or use the shortcut, the note will be pasted into the rough centre of
the view; when you select Paste from the contextual menu (right-click, or ctrl-click
if your mouse or trackpad is not configured to use two buttons), the note will be
pasted at the point where you right-clicked.

Scapple notes can be copied and pasted from one board to another, and can even be
pasted as text into a text editor like Scrivener or Microsoft Word. Read more about
importing and exporting via Copy and Paste (subsection 9.2.3).

4.2.6 Resizing Notes

To resize a note:

1. Move the mouse over the left or right edge of the note, until the cursor changes to
the resizing handle icon. Images can be resized from any side?, as can background
shapes (section 4.4).

2See Getting Work Into Scapple (section 9.1) for information on how to import images.
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2. Click and drag the mouse left or right to make the note narrower or wider. Text
notes will rewrap, automatically getting taller or shorter, to fit the text to the new
note width.

Resizing Notes from the Middle: For notes that have been centre aligned, or just in
any case where you would like to resize the note from the middle of it rather strictly
left or right, you can hold down the Option key while dragging. This also works for
Shapes, in the up and down direction.

To resize multiple notes:

1. Select all the notes you want to resize.

2. Move the mouse over the left or right edge of any one of the notes, until the cursor
changes to the resizing handle icon.
3. Click and drag the mouse left or right to make all selected notes narrower or wider.

When multiple notes are selected, you can make them all the same width by using
the Notes » Make Same Width menu command. This will not align them (use the
Notes » Align » sub-menu for that), merely resize them in place. Images and back-
ground shapes can have their height equalised as well, with Notes » Make Same
Height.

4.2.7 Deleting Notes

Deleted notes are removed immediately from the board, but you can always use Edit/
Undo if you make a mistake.

1. Select the notes you wish to delete.

2. Use Edit » Delete or hit the Delete key on the keyboard.

4.2.8 Splitting and Merging Notes
Sometimes, you may have long notes that you wish to split up into smaller notes, or you
may have a bunch of related notes that you wish to merge into one.

< Single notes can be split into two notes:

1. Double-click into a note to edit it.
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2. Place the blinking insertion point caret at the point in the text where you
want to split the note (you can ignore whitespace, all extra spaces and carriage
returns will be trimmed from both notes after splitting).

3. Choose Notes » Split (38K). The new split note will be created stacked under-
neath the existing note.

< A specific selection of text can be split off into a new note:

1. Double-click into the note containing the text to edit it.

2. Select the text you wish to split into a new note.

Portions of this note will be split Portions of this note will be left
from the rest with the remainder left alone.
alone.
split from the rest with the
remainder
Figure 4.5:

3. Choose Notes » Split. A new note will be created containing the selected text,
stacked directly underneath the existing note. The selected text will be re-
moved from the original note.

< Merging several notes:

1. Select the notes you wish to merge, ensuring that the first note you select is
the one you wish the notes to be merged into. The remaining notes in the
selection will be sorted based upon their distance from the first.

2. Choose Notes » Merge.
See Also:

4 Stacks (section 4.5).

4 Selecting Notes (subsection 4.2.2).
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4.2.9 Changing the Appearance of Notes

You can change the appearance of notes in several ways:

< Add a coloured border.

< Change the fill (background) colour of notes.
< Change the text colour.

< Make text bigger or smaller.

< Add bold, italics, underline or strikethrough.
< Change the overall shape of the note.

4 You can also change the font and background colour used for the Scapple board.

To change the appearance of notes, select the notes you wish to affect, and then use
one of the following methods:

< Use the Inspector, which can be opened by choosing View » Show Inspector (\01).

4 Use the commands available in the Format Menu (section B.6). A selection of
common commands can be accessed from the right-click contextual menu.

< Apply a note style preset using the Format » Note Style » Apply Note Style » sub-
menu (also available in the contextual menu).

See Also:

< The Inspector (chapter 10)
< Formatting and Appearance (chapter 6)
< Note Style Presets (section 6.3)

4.2.10 Aligning Notes

Notes can be aligned along several different edges or axes:

1. Select the notes you wish to align. The first note you select will not be moved—
other selected notes will be moved to align with the note that was selected first.

2. Go to the Notes» Align» sub-menu and then choose from “Left Edges”, “Right
Edges”, “Top Edges” or “Bottom Edges”.
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3. Aligning by “Horizontal Centers” will cause the notes to end up in a column,
aligned by their horizontal width. Aligning by “Vertical Centers” will result in a
row, with their vertical middles used to determine the placements.

If you want to arrange notes into a single column, it is often more useful to “stack”
them rather than align them (section 4.5).

4.2.11 Arranging Overlapping Notes

You will most likely wish to avoid having notes arranged on top of each other, as this will
often result in text being obscured and thus make things difficult to read. However, there
may be occasions where you have a note partially overlapping another and you wish to
arrange their front-to-back order, so that the note underneath is brought to the front, or
vice versa. This is easy to do.

Bring a note partially obscured by other notes to the front:

1. Select the note you wish to bring to the front.

2. Use Notes » Bring to Front (X 88}).

Alternatively, right-click on the note and select “Bring to Front” from the contex-
tual menu.

To send a note obscuring another note to the back:

1. Select the note you wish to send to the back.

2. Choose Notes » Send to Back (\8{).

Alternatively, right-click on the note and select “Send to Back” from the contextual
menu.

Background shapes, as their name implies, are always located on the bottom layer
beneath all notes. They can however be arranged among themselves, using these same
commands.

4.3 Connections

When you’re throwing ideas around on the page, some notes exist in isolation, while
others are connected. In Scapple, you are free to connect your ideas however you like.
Any note can be easily connected to any other note—making connections is as simple as
dragging and dropping one note onto another. Notes can be connected by simple dotted
lines, or by lines with arrows at either both ends.
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Connections in Scapple, unlike those in most diagramming and mind-mapping appli-
cations, don’t have any internal meaning’, and are fundamentally a means of connecting
your ideas visually, just as you might draw lines or arrows between notes on a piece of

paper.

4.3.1 Creating Connections Between Notes
Two or more notes can be connected with a dotted line:

1. Drag one note over the top of another note—notice that when you do so, the cursor
changes to a curled arrow and the note beneath the pointer becomes darker, to
indicate that a connection will be made when you drop.

2. Release the mouse button to drop the dragged note onto the other. A dotted line
will now connect the two notes (the notes will stay in their original positions).

Alternatively, select the notes you wish to connect and choose Notes » Connect
(>). The note you select first will be the one they connect to. This command is
also available from the contextual menu.

If you would like to connect all of the selected notes together, use Notes » Connect All.

Two or more notes can have arrows drawn between each other:

1. Dragone note over the top of another note—notice that when you do so, the cursor
changes to the curled arrow and the note beneath the cursor becomes darker, to
indicate that a connection will be made when you drop.

2. Hold down the Option key before you release the mouse button to drop the dragged
note onto the other. A line will connect the two notes, with an arrow pointing
from the dragged note towards the note onto which you dropped it.

Note that if you then Option drag-and-drop in the opposite direction (dragging the
note you previously dropped onto and dropping it onto the note you previously
dragged), this will result in the connecting line having an arrow at either end.

3. In the same fashion, hold down the Option and Command keys together when
dropping to create an arrow pointing from the note you dropped onto, pointing
back to the initial selection.

Alternatively, select the notes you wish to connect and choose Notes » Connect
Wwith Arrow (X &.). The arrows will point from the first note selected to

3They can have some effect on the order in which notes are exported to text formats; see Getting Work
Out of Scapple (section 9.2).
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subsequently-selected notes (see the Selecting Notes section for more information
on selecting notes). This command is also available from the contextual menu.

Notes can also be connected as they are created (subsection 4.2.1).

4.3.2 Removing Connections

You remove connections in the same way as you create them:

1. Drag one note over the top of another note to which it is currently connected—
notice that when you do so, the cursor changes to the curled arrow and the note
beneath the cursor becomes darker, to indicate that the drop operation will affect
the connected status.

2. Release the mouse button to drop the dragged note onto the other. The connection
between them will disappear.

Alternatively, select all of the notes you wish to disconnect and choose
Notes » Disconnect (3¢ <). This command is also available from the contextual menu:

< When selecting individually connected notes, other notes that these selected notes
may be connected to will not be affected by this command.

< When only a single note is selected, then this command will destroy all connections
between it and other notes.

4.3.3 Changing Connection Types
To change an existing connection between two notes from a dotted line to an arrow, or
vice versa:

1. Drag one note over the top of another note to which it is currently connected—
notice that when you do so, the cursor changes to the curled arrow and the note
beneath the cursor becomes darker, to indicate that the drop operation will affect
the connected status.

2. Holding down the Option key, release the mouse button to drop the dragged note
onto the other. If the connection between the notes was previously a dotted line, it
will now be an arrow pointing from the dragged note to the note onto which you
dropped it; if the connection between the notes was formerly an arrow, if there
is no arrow at the other end of the line it will now be a dotted line, or if it was
previously a line with arrows pointing in both directions, it will now only have an
arrow pointing in one direction.
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Alternatively, select the notes you wish to affect and choose Notes » Connect With Ar-
row (\$.) or Notes » Remove Arrows (X 8,). The “Connect With Arrow” command will
only make arrow connections from the first note selected to subsequently-connected ar-
rows; it will not make arrow connections between every single note.

4.3.4 Moving Connected Notes

When two notes are connected, you can move them both together simply by clicking
and dragging the connecting line between them. See Moving Notes (subsection 4.2.4) for
more information about moving notes around.

4.4 Background Shapes

If you're like me, sometimes you want to draw a big circle around a group of ideas. It’s an
easy way of associating a group of concepts and treating them—for some purposes—as a
single entity. In Scapple, Background Shapes accomplish this form of thinking, without
adding a lot of complexity. By and large, a background shape acts like a note—it can
be dragged around and selected in the same way, and can have many of the same styles
applied.
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bvailable in menus too J \1
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merge?
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- ( A Move N
uble-click .
bate a QuickZoom Allow nof
ed note. using arr

Hold down “z” to zoom out, let go mode.
shortcuts for again to zoom back in on the
tc. mouse position.
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Space bar drag-scrolling too. Zoom to Selection” t00.
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Figure 4.6: A background shape, indicated by the red arrow, encloses four notes.

There are a few important differences that set shapes apart from notes:

< They cannot ever hold text by themselves. That is what notes are for.
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< In addition to dragging their left and right sides, they can be resized by the top and
bottom, or in two directions along their four corners.

< Optionally, background shapes can become “magnetic”, which means that overlap-
ping notes will stick to them when they are moved.

< They always occupy the bottom “layer”, beneath all notes. Background shapes can
be brought forward and backward amongst themselves, but they can never overlap
a note.

A shape considers a note or shape to “belong” to it, if any part of the item overlaps said
shape. This impacts Edit/Select/Overlapping Notes, what gets moved or copied with the
shape when it is Magnetic (subsection 4.4.4) and when using export formats that support
nesting.

4.4.1 Creating Background Shapes
There are two ways to create shapes. You may already have a collection of ideas you wish
to “draw a circle around™:

1. Select the notes you wish to enclose.

2. Use the Notes » New Background Shape Around Selection menu command. The
new shape will be sized to fully enclose all of the selected notes.

Sometimes you need to create a topic that you intend to fill with new ideas:

1. With nothing selected, use the Notes » New Background Shape menu command.

2. A new shape will be created in the middle of the current view, which may be be-
neath other notes. It can now be moved to a free spot if desired.

4.4.2 Selecting Shapes
Shapes can be selected in the same manner as notes (subsection 4.2.2). You can click
anywhere in the middle of a shape to select it. There is no need to click precisely on the

edge.

4.4.3 Selecting Contained Notes
If you need to select all of the notes (and potentially shapes within shapes) within a shape:

< Simply hold down the Option key and click anywhere within the shape.
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¢ Use the Edit » Select » Overlapping Notes ~ % A menu command.

< Marquee selection can be used within a shape by holding down the Command key
to temporarily disable selecting the shape itself and dragging it.

How To Select Just the Enclosed Notes: If you want to select just the enclosed
notes within a shape, but not the shape, perform one of the aforementioned steps to
select overlapping shapes, and then hold down the Command key and click in the
background shape to toggle its selection state.

4.4.4 Moving Shapes and Notes Together (Magnetic)
While you could continue to use the ability to select overlapping notes to move shapes
around together with the notes they enclose, you might wish for a more automatic solu-

tion. Setting a background shape to be “magnetic”, using Notes » Magnetic accomplishes
this.

A shape can be set to magnetic whether or not any notes are currently enclosed within
it. The setting is a feature of the background shape, not of the notes within it. This
means that dragging a magnetic shape beneath a group of notes and then back out again
will “vacuum” all of the notes it came in contact with. If you are familiar with digital
diagramming and visual outlining software, you might intuitively consider background
shapes to be a form of “containment”; that the notes within the shape are somehow inside
the shape. While true to a very minimal extent, it is better to think of the notes as being
on the shape. The shape does not own the notes that overlap it, for indeed a note with a
“fuzzy” concept might overlap more than one shape.

Dragging a magnetic shape with the Options key held down will create a duplicate of
that shape and any items overlapping it.

To toggle whether a background shape is magnetic:
1. Select the shape(s) you wish to set to toggle magnetism on.

2. Use the Notes » Magnetic ({+$ M) menu command.

< If any of the shapes are already magnetic, they will remain so.

4 If all of the selected shapes are in the same state, then they will be toggled on
or off together.
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Figure 4.7: When dragging a magnetic shape, the drag “ghost” shows the enclosed notes
that will move.

Using Shapes as Handles: Magnetic background shapes will grab on to any overlap-
ping notes, and as such they do not necessarily need to fully enclose a note to drag it
around. Shapes on the other hand do need to be fully enclosed to be dragged along
with the larger shape.

4.4.5 Connecting Shapes

Since dragging notes onto shapes is a fundamental task, the ordinary behaviour of drop-
ping one thing onto another to connect them is disabled. However a shape can be dropped
onto a note (or another shape) to connect the two. Because of this, if you wish to draw
an arrow pointing from a note to a shape, then you must start the drag from the shape
and hold down the Option and Command keys together, to draw an inverse arrow.
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4.5 Stacks

Notes can be stacked on top of one another to create “lists”, or columns of text (2?).
When notes are in a stack, changes to the height of one of the stacked notes will cause the
notes in the stack below it to be moved up or down automatically. For instance, if you
have three notes in a stack and edit the second one, as you add text to the second note
(resulting in it getting taller) the note below it will move down; if you remove text so that
the second note becomes shorter, the note below it will move up.

This is a “stack” of notes.
They can be easily created with 3§ <
Stacks will shift notes to make space

for new notes, or when an edited note
wraps to a new line.

Figure 4.8: A “Stack” of notes with a background fill to demonstrate placement.

Stacks are useful for maintaining a list of related ideas that don’t belong in a single
note. When notes aren’t stacked, if you make edits to a note so that it becomes longer,
it may begin to overlap notes below it, making it necessary to move things around after
you have finished editing. By stacking notes, you avoid this problem, as notes in the stack
will move up or down as necessary to avoid any overlap or empty spaces. Additionally,
new notes can be created in the middle of the stack, or removed.

4.5.1 Creating a Stack

To create a stack from existing notes:

1. Select the notes you wish to arrange into a stack. The first note you select will not
move, and subsequent notes will be placed under the first note in order of distance
from the first selected note.

2. Choose Notes» Stack (3°). This command is also available from the contextual
menu.

You may optionally at this point wish to use the Notes » Make Same Width com-
mand to tidy up the stack.
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4.5.2 Creating a New Note in a Stack

To create a new note in a stack (as well as to create a new stack from scratch):

1. Select the note in the stack underneath which you wish to create the new note.

2. Choose Notes » New Stacked Note (3¢Return). The new note will be created beneath
the selected note and any notes that were previously below the selected note in the
stack will be moved down so that they are now beneath the new note.

4.5.3 Deleting Notes in a Stack

To delete notes from a stack, you follow the same procedure as usual for deleting notes
(subsection 4.2.7):

1. Select the notes you wish to delete.

2. Choose Edit » Delete or hit the Delete key on the keyboard. Any notes below the
deleted notes in the stack will be moved up so as to maintain the stack.

4.5.4 Moving Notes Out of a Stack

To move a note out of a stack, simply drag it to a different location. When moving notes
out of the middle of a stack, any notes below them in the stack will automatically be
moved up to remove the gap it would otherwise leave behind, much like when deleting a
paragraph of text in a text editor.

4.5.5 Moving Notes Into a Stack and Reordering Them

To move an existing note into a stack, simply select the note in the stack that it should
appear beneath, then hold down the Command key and select the note(s) you wish to
add to the stack. Use the Notes » Stack menu command to insert the selected notes.

This trick can also be used to reorder notes within a stack. First, select the note the
stacked notes should be moved beneath, and then each note you wish to move. Notes
will be placed in order using their distance from the initial note, so multiple notes can be
gathered together beneath another in this fashion.

4.5.6 Indenting Within a Stack

If you are using a stack to create a list of items, it may at times be useful to indent portions
of the stack. If you try and move or resize these notes normally, the stack will be broken.
Instead, use the dedicated indentation feature, which will block indent the text of the
note without changing its width or position:
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1. Select the notes you wish to indent or outdent.

2. Press Tab to indent (or demote) notes by 1em. Use 43 Tab to outdent (or promote)
the selected items. Text cannot be outdented beyond the left-margin of the note.

In some cases you will want to resize notes after indenting them, particularly if they
were narrow to begin with. While selected, all notes can be resized together (subsec-
tion 4.2.6).
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Chapter D

File Management Essentials

This 1s the part where we risk trying teach your grandmother to suck eggs—if you know
your way around a Mac, you can safely skip this section, as it just covers how to create,
open and save Scapple documents (or “Scapple boards”). If you’re familiar with creating,
opening, saving and managing files in other applications such as TextEdit, you already
know how to do all of this, as Scapple works the same.

5.1 Creating a New Scapple Document

Usually you will want to start with a blank Scapple board when embarking on a new
project, but sometimes you might want to start your work based on a copy of an existing
one.

5.1.1 Starting a New Blank Document
1. In Scapple, choose File » New (§2N).

2. A new window containing a blank canvas will appear. Double-click anywhere on
the canvas to start adding notes.

3. When you’re done, choose File » Save... (§£S).

5.1.2 Starting a New Document Based on an Existing Document

On OS X 10.7 and above, Scapple uses the new autosave features built into the operating
system. Read more about these features in Using Autosaved Versions of Your Scapple
Boards (section 5.4). Briefly:

1. In Scapple, choose File » Open..., and then select the file you want to use as a start-
ing point.

2. Choose File » Duplicate. On Mac OS 10.8 you will be prompted for a new name
which you can type directly into the title bar of the new window. Holding down
the Option key will change this menu command to the more familiar, “Save As...”.

33
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3. Edit the new document that is created.

4. When you’re done, choose File » Save. If you haven’t already chosen a name for
the new document, you’ll be prompted for one at this time.

On OS X 10.6:

1. In Scapple, choose File » Open, and then select the file you want to use as a starting
point.

2. Choose File » Save As... and choose the file name and location for the new docu-
ment.

Creating Templates: If you have a starter board you anticipate using frequently to
create new files, you can select the document in Finder, and use the File » Get Info
menu command, or 1. In the “General” section of this palette, you’ll see an option
named, “Stationery pad”. When this is enabled, the original document will never be
opened directly. Instead a new copy will be created from it automatically.

9.2 Saving a Scapple Document

On OS X 10.7 and above, Scapple automatically saves your documents continuously as
you work on them, so you don’t explicitly need to save your changes unless you want to
name or rename a document. It is still always a good idea to save manually from time
to time, though, and you will also want to use Save to specify the location on your hard
disk you want to keep the file. Skip to Using Autosaved Versions of Your Scapple Boards
(section 5.4) to read more about it.

5.2.1 Save and Name a New Document
1. In Scapple, choose File »- Save....

2. Name the document, select a location, and then click the Save button.

5.2.2 Save and Rename a Copy of a Document
On OS X 10.7 and above:

1. In Scapple, choose File » Duplicate.

2. Choose File » Save.
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3. Name the document, select a location, then click the Save button.
On OS X 10.6:

1. In Scapple, choose File » Save As....

2. Name the document, select a location, then click Save.

5.3 Opening Existing Scapple Documents

Scapple can only open files created with Scapple. You can recognise a Scapple file by its
extension—Scapple files end with the extension “.scap”—or by its Kind, “Scapple Map”.
To open an existing document, do one of the following:

< In Scapple, choose File » Open.. ., find and select the document, and then click the
Open button. ([Mac App Store Version] If iCloud is available, you can click
“iCloud” in the top-left corner to find an iCloud document.)

< In Scapple, use the File » Open Recent» sub-menu, and then choose the docu-
1
ment.

< In the Finder, locate the document, and then double-click it or drag and drop the
file to the Scapple application icon.

9.4 Using Autosaved Versions of Your Scapple

Boards
[Mac OS X 10.7+] Autosave is only available on OS X version 10.7 and above. If you
are running OS X 10.6, you should skip this section.

Scapple automatically saves versions of documents as you work on them. At any time,
you can browse through document versions and go back to an older version. You can
also explicitly save a version.

A version is saved automatically every hour, or more frequently when you’re making
many changes. A version is also saved when you open, save, duplicate, lock, rename, or
revert a document.

5.4.1 Browsing, Restoring, Duplicating and Deleting Versions
1. Hold the mouse pointer to the right of the document title at the very top of the
window. A small downwards-pointing arrow will appear on the right. (You may

"The number of recent documents displayed is configurable via the “General” System Preferences pane
on your Mac.
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Bs  Format Window Help
| | ScappleSample.scap — Edited v

Rename...
Move To...
Duplicate

Lock

Last Opened

:Versions...

Figure 5.1: The document version management menu.

see the word “Edited” in grey, as depicted in the document version management
screenshot (??), when the file contains new changes.)

. Click the arrow—a menu will appear.

. Choose “Browse All Versions”. The current Scapple board window will be ar-

ranged on the left and a stack of windows containing all previous versions will be
arranged on the right.

. Click the tickmarks along the timeline on the right of the screen to browse versions

through time. (Or click on the black title bars behind the Scapple window on the
right.) Grey marks represent versions stored on your internal hard drive. Pink
marks represent versions stored on your backup disk.

. Do one of the following:

4 To restore your document to a previous version, display the version, then
click Restore.

4 To duplicate a version in a new document, display the version, then press the
Option key, and click “Restore a Copy”.

< To delete a version, display the version, hold the pointer to the right of the
title, click the arrow, and then choose “Delete This Version”.

4 To delete all versions, press the Option key while holding the pointer to the
right of a version’s title, click the arrow, and then choose “Delete Old Ver-
sions”.

To leave your document as-is, without changes, click Done.
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5.4.2 Explicitly Saving Versions
¢ On OS X 10.8 and above, choose File » Save.

¢ On OS X 10.7, choose File » Save a Version.

Taking Care of Versioned Files: Your Mac will use an advanced feature to save each
individual version in such a way that the old copies do not get in your way (such as
when using “Save As...”. These versions are saved into a special portion of the disk
that is tied to the visible file. Because this relies upon proprietary Mac technology,
versions will be lost forever if the file is transferred to another computer using a
method that is not specifically Mac technology. For example, if the file is transferred
automatically between computers using Dropbox, the versions will be aggressively
discarded whenever switching machines. Likewise versions will not survive when
e-mailed or transferred via Windows file sharing networks, or when stored on disks
that are not formatted with HFS+.

It is therefore recommended that you periodically save separate duplicates of files and
keep them safe as backups, especially when using synchronisation tool or collabo-
rating with others. This may already be done if you use Time Machine or another
periodic backup system.

5.4.3 Reverting Documents to the Previous Version

If you have unsaved changes in a document, you can revert it to its last saved or last
opened version:

| ] ScappleSample.scap — Edited «

Rename...
Move To...
Duplicate

Lock

Last Saved — Today 18:53

Last Openeﬁv
Browse All Versions...

Figure 5.2: Reverting to the last saved version.
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< Hold the mouse pointer to the right of the document title at the top of the window
so that the downwards-pointing arrow appears.

4 Click on the arrow to bring down the Versions menu (??).

< Choose “Last Saved”, “Previous Save” or “Last Opened”.

9.5 Moving Scapple Documents

Scapple documents are saved as regular files to your hard disk. The easiest way of moving
them to new locations is to use the Finder to copy, cut, paste or drag and drop your files.

If you are running OS X 10.8 and above, you can also move documents using the title
bar menu, as follows:

1. Hold the mouse pointer to the right of the document title at the top of the window
so that the arrow appears.

2. Click on the arrow to bring up the menu.

3. To move the document elsewhere on your hard drive, select “Move To”, choose a
location, and then click “Move”. (Choose “Other...” from the bottom of the list
of locations to open the full Save panel.)

[Mac App Store Version] If you purchased Scapple from the Mac App Store, you
also have the option of choosing “Move to iCloud” from this menu. See Using iCloud
(section 5.7) for more information.

Circumventing File Management: Care should be taken when using the “Rename”
and “Move To” commands from within Scapple, if the files are stored within some
form of container, like a database or a Scrivener project. In most cases, the position
and name of the file is important to the software that is organising them, and changing
either of these parameters can cause the containing software to lose track of your files.

5.6 Finding and Locating Scapple Documents

If you aren’t sure where a particular Scapple file is located on your hard disk, there are a
couple of ways of finding it:

< If you have the file open in Scapple, or can open it via the File » Open Recent »
sub-menu, then you can right-click or Command-click on the document title (or



5.7. USING ICLOUD 39

icon) at the top of the window. This will open a menu showing the path to the file
on disk in an ascending order of hierarchy, all the way to the volume or disk it is
stored on. Choose the second item from the top in the list, which will be a folder,
to open the Finder with the file selected.

< If you don’t have the file open in Scapple and it is not available in the File » Open
Recent» sub-menu, the easiest way to find your files is to use Spotlight. You can
either type the name of the document into Spotlight (including the .scap extension
for best results), or a snippet of text that you know occurs in the document.

< Using Spotlight to search for “.scap” all by itself will return a list of all Scapple
documents indexed by Spotlight. It is important to know that Spotlight can have
blind spots—either intentionally imposed by privacy settings, or with some types
of removable media.

5.7 Using iCloud

[Mac App Store Version] iCloud data-storage is only available to users running OS X
10.8 or above, and who bought Scapple through the Mac App Store. This is a limitation
imposed by Apple, not by us—only applications purchased from the App Store (and
Apple’s own programs, such as TextEdit) are permitted iCloud access.

If you turn on the Documents & Data service in the “iCloud” System Preferences pane,
iCloud-enabled apps can store your documents on the iCloud servers. You can then use
Scapple to open and save documents directly in iCloud. You can access your documents
in iCloud, with all your latest updates intact, using more than one Mac running OS X
Mountain Lion or greater.

To enable iCloud:
1. Choose “System Preferences” from the Apple menu, then click the “iCloud” icon.
2. If you are not already signed in, sign in with the Apple ID you use with iCloud.

3. Select “Documents & Data”.

Once iCloud is enabled, the standard Open panel will look different. In Scapple, go
to File » Open... to bring up the Open panel. There are now two options in the top-left
corner:

4 iCloud: Selecting this presents you with a list of Scapple documents that have been
saved to iCloud, if any.
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< On My Mac: Selecting this presents you with the regular Open panel, for opening
files from your hard disk.

You can move documents to and from 1Cloud by dragging between the Finder and the
list of documents in the “iCloud” pane.
Select “New Document” at the bottom of the “iCloud” pane to create a new document

on iCloud.
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Formatting and Appearance

Scapple is designed to focus on getting ideas down quickly, so it deliberately avoids pro-
viding too many distracting bells and whistles that could turn a planning and thinking
session into a making-it-look-pretty session.

That said, you can change the
background colour, default text
colour and font of your Scapple

boards, and yl"\ll ran annhs o
number of sty That said, you can change the
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That said, you can change the
background colour, default text
colour and font of your Scapple
boards, and you can apply a
number of style options to individual
notes, from changing the font
appearance (such as applying bold
and italic) to giving notes borders
and fill colours.

Figure 6.1: Just a few of the possibilities available for styling notes.

That said, you can change the background colour, default text colour and font of your
Scapple boards, and you can apply a number of style options to individual notes, from
changing the font appearance (such as applying bold and italic) to giving notes borders
and fill colours.

41



42 CHAPTER 6. FORMATTING AND APPEARANCE

Finding These Instructions Confusing? This section of the guide has been written
under the assumption that you already know the basics, as covered in Learning the
Ropes (chapter 4), such as selecting notes, making new ones, and what the differences
are between connected notes, stacks, and background shapes. If you haven’t already
done so, you should go through that chapter. It is brief, and we’ll be here waiting for
you when you get back.

6.1 Changing the Appearance of a Scapple
Board

By default, new Scapple boards use a beige, vellum-coloured background with black text
and connectors. Notes will use the Helvetica font and the writing direction runs from
left to right.

All of this can be changed via The Inspector (chapter 10). For all of the instructions in
this section, you will want to open the Inspector to the “Document” tab:

1. Open the Inspector by choosing View »- Show Inspector (X &1).

2. Select the “Document” tab in the Inspector.

6.1.1 Changing the Background Colour
To change the background colour of a Scapple board:

1. Open the “Document” tab of the Inspector, as described previously.

2. Click on the colour well in the “Background Color” section to change the back-
ground colour of the Scapple board. Note that this will only affect the current
Scapple document—each Scapple board can use a different background colour.

3. To reset the background colour to the default beige, click on Use Default.

6.1.2 Using a Background Texture

If you have a background texture you would like to use (such as graph paper, or wood
panelling), follow these instructions to apply the texture to your board:

1. Open the “Document” tab of the Inspector.

2. Click the Use Texture... button, below the colour selection tool.
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8 00 Inspector

| Note Style
Background Color

[ 9| | useDefault |

| Choose Texture... |

Text Appearance

Default Color:

| IN Clear

Font:

| Helvetica a

Writing Direction:

| Left to Right s

Set As Defaults

Figure 6.2: The “Document” tab of the Inspector.

3. Use the file browser to locate and select a suitable background texture.

A background texture will override any chosen colour for the board (a preview of
the texture will be shown in the colour well to signify this). To remove the texture,
simply click the Use Default button, or choose a colour with the picker. As with a default
background colour, this will only change the current Scapple board.

Choosing a Good Background Texture: Not every graphic file will make a good
texture. The best files are small, and designed to be “tiled”, so that when they are
repeated over and over, no visible breaks or seams can be detected (unless that is
intentional, such as with a chess board). Larger graphics may be used, but understand
that this will both increase the size of the document as well as how much computer
memory it must take up to display the board. Large graphics may slow down Scapple
and make it difficult to use.

6.1.3 Changing the Default Text Colour

The default text colour is used by all notes that don’t explicitly have a colour assigned to
them (you can apply a text colour to individual notes using the “Note Style” tab of the
Inspector to override the default colour for those notes).
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A background texture can add a
nice touch to the look of your
Scapple boards.

They can even make you feel more
productive!

Figure 6.3: A Scapple board using a leather background texture (no digital sheep were
harmed).

To change the default text colour for a Scapple board:

1. Open the “Document” tab of the Inspector.

2. Click on the “Default Color” colour well in the “Text Appearance” section and
choose a colour from the colour palette that opens. Note that this will only affect
the current Scapple board.

3. Click on “Clear” to reset text and connections to whatever will contrast best with
the current background colour.

6.1.4 Changing the Font Used by Notes
To change the font used by notes in a Scapple board:

1. Open the “Document” tab of the Inspector.

2. Choose a font from the “Font” drop-down menu. Note that this will only affect
the current Scapple board—each Scapple board can use a different font. The new
font will be applied to each note in the Scapple board (notes cannot use different
fonts).
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Choosing a Good Font: Not all fonts support bold and italics, so if bold or italics
aren’t available, try choosing a different font. Likewise, if you choose a new font and
find that bold and italics get wiped from your document, hit undo (Edit» Undo or
$8Z) and try choosing a different font.

Be aware that different fonts have a variety of dimensions, so if you change the font for
a Scapple board that already has lots of notes in it, the notes may seem to move around
to accommodate the new font (stacks will in fact adjust their positions as necessary). It’s
therefore usually better to decide on a font early on in the Scapple board’s gestation.

6.1.5 Changing the Writing Direction
Users who write in a language that runs from right to left instead of from left to right
can change this via the Inspector (or the Format » Writing Direction menu) as follows:

1. Open the “Document” tab of the Inspector.

2. Choose “Right to Left” under “Writing Direction”.

Note that the writing direction setting affects the way stacks are detected and the way
notes get resized, too, changing everything to work from right-to-left, not just typing.

6.1.6 Changing the Default Appearance

If you would rather new Scapple boards use your own preferred appearance settings
rather than the default beige background and black text, you can easily set this up via
the Inspector as follows:

1. Open the “Document” tab of the Inspector.

2. Set up the options for background colour, text colour, font and writing direction
as you wish them to be set for the current document and all new documents.

3. Click on the Set As Defaults button at the bottom of the inspector.

Whenever you create a new Scapple board by choosing File » New..., its appearance
will be based on these options.
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6.2 Note and Shape Style Options

Individual notes (and in some cases, ranges of text within them) as well as background
shapes can have their formatting changed in the following ways:

< You can apply bold, italics, underlining or strikethrough to the text of each note.
These options can be applied either to whole notes or to ranges of text within notes.

< You can change the text size of each note. Text size changes can only be applied to
entire notes, not to ranges of text within notes. Since shapes can never hold text,
this setting will be disabled for them.

4 You can set the text colour of each note, overriding the default text colour. This
setting does not apply to shapes.

< You can apply a coloured border to each note or shape, and choose the thickness

of the border.

< The style of the border can be changed to square, jagged, cloud or rounded (which
is the default).

< You can choose whether each note or shape has its own background (fill) colour or

not.!

< You can “fade” notes and shapes, causing them to merge into the background. This
can be useful for temporarily taking some notes out of the limelight. When shapes
are faded, the notes that are overlapping them will appear faded also. This doesn’t
change the state of these notes themselves. If they are dragged out of the shape,
they will return to full opacity.

All style changes can be made using the The Inspector (chapter 10), or various menu
commands and keyboard shortcuts. To call up the inspector for changing note styles:

1. Use the View » Show Inspector menu command (\C$81).

2. Click on the “Note Style” tab, if necessary.

See also: Note Style Presets (section 6.3).

"Notes will always technically have a fill, rather than being truly transparent. This is to keep the board
clean and easy to read when many connection lines intersect beneath a note. When no fill is chosen, the
background colour of the board will seamlessly be used.
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Document |
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Figure 6.4: The “Note Style” tab of the Inspector.

6.2.1 Applying Bold, Italics, Underline and Strikethrough

Unlike most other note styles, the four basic font variations and adornments can be
applied to entire notes, or only to selections of text within the note itself.

Using Boldface

To apply or remove boldface on a note, do one of the following:

< To make whole notes appear in bold, select the notes you wish to affect and choose
Format » Font » Bold (or hit $¢B).

Alternatively, select the notes you wish to affect, call up the Inspector (View » Show
Inspector or 1), ensure the “Note Style” tab is selected, and click the “B” button
under “Text Style”.

< To apply boldface only to certain ranges of text within a note, first double-click the
note to edit it, then select the text you wish to affect.

4 To remove boldface from a note, repeat the above process—the Bold command
toggles boldface on and off for both text and whole notes.
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Using Italics
To apply or remove italics on a note, do one of the following:

< To make whole notes appear in italics, select the notes you wish to affect and choose
Format » Font » Italic (or hit $1).

Alternatively, select the notes you wish to affect and click the “I” button under

“Text Style” in the “Note Style” tab of the Inspector.

< To apply italics only to certain ranges of text within a note, first double-click the
note to edit it, then select the text you wish to affect.

4 To remove italics from a note, repeat the above process—the Italic command toggles
italics on and off.

Using Underlining

To apply or remove underlining on a note, do one of the following:

¢ To underline whole notes, select the notes you wish to affect and choose For-
mat » Font » Underline (or hit $8U).

Alternatively, select the notes you wish to affect and click the “U” button under
“Text Style” in the “Note Style” tab of the Inspector.

< To underline only certain ranges of text within a note, first double-click the note
to edit it, then select the text you wish to affect.

4 To remove underlining from a note, repeat the above process—the Underline com-
mand toggles underlining on and off.

Using Strikethrough

To apply or remove strikethrough on a note, do one of the following:

4 To strike through whole notes, select the notes you wish to affect and choose For-
mat » Font » Strikethrough (or hit Shiftg -).

Alternatively, select the notes you wish to affect and click the struck-through “S”
button under “Text Style” in the “Note Style” tab of the Inspector.

< To strike through only certain ranges of text within a note, first double-click the
note to edit it, then select the text you wish to affect.

4 To remove strikethrough from a note, repeat the above process—the Strikethrough
command toggles strikethrough on and off.
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6.2.2 Changing the Text Size

To change the text size of selected notes, do one of the following:

4 Select the notes you wish to affect and choose Format »- Font » Bigger (3¢ +) or For-
mat » Font » Smaller (88 -).

< Alternatively, select the notes you wish to affect, call up the Inspector if it is not
already visible, then use the slider, text field or stepper under “Font Size” in the
“Note Style” tab.

Text size can only be applied to an entire note, so even if you are editing the text of the
note and select a range of text within it, these commands will still only affect the whole
note.

6.2.3 Changing the Text Colour of Individual Notes

How Default Note Colours Work: The following describes how to set the text
colour for individual notes. To set the default text colour used by all notes in a doc-
ument, see Changing the Default Text Colour (subsection 6.1.3). The default text
colour is used by notes that don’t have a specific text colour set; or, to put it another
way, when you apply a text colour to individual notes, as described below, that over-
rides the default text colour but setting a default colour will not override individual
note settings.

To apply a separate text colour to notes, first select the notes you wish to affect, then do
one of the following:

< Choose Format » Colors » Change Text Color... This will bring up the colour
palette, where you can choose the new text colour.

< Click on the “Text Color” colour picker in the “Note Style” pane of the Inspector.
This will call up a popover with a selection of colours from which to choose, or if
you want a custom colour, click on “Show Colors. ..~ at the bottom of the popover
to bring up the full colour palette panel.

To clear the text colour from notes so that they use the default, do one of the following:

4 Choose Format » Colors » Clear Text Color.
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4 Click on the “Text Color” colour picker in the “Note Style” pane of the Inspector
and choose the white square with the diagonal red line through it in the popover
that appears.

Text colour can only be applied to an entire note, so even if you are editing the text
of the note and select a range of text within it, these commands will still only affect the
whole note.

6.2.4 Applying Borders to Notes & Shapes

Both background shapes and notes can have a variety of border styles applied to them
individually, or as defaults. To apply a border to notes or shapes, first select the items
you wish to affect (notes and shapes can be selected together, if desired), then do one of
the following:

1. Use the Format » Border » sub-menu to choose a border thickness, or “No Border”
to remove an existing border. These options are also available in the contextual
(right-click) menu.

2. Choose a border thickness from the drop-down menu at the bottom of the “Note
Style” pane of the Inspector.

In the supplied figure (2?), all six border thicknesses (including none at all) are displayed
within the box on the left side. The Inspector is also shown with the “Thickness” drop-
down menu enabled and the three pixel border option highlighted.

Why Doesn’t the Border Thickness Change Immediately? While a note or shape
is selected, the thickness of the border will be intentionally obscured behind the se-
lection halo. This is to increase the clarity of what is selected and not, but has the
side-effect of making changes to the selection invisible until that selection is removed.

Changing Border Colours
To apply a colour to the border, first select the items you wish to affect, then do one of
the following:

1. Choose Format » Colors » Change Border Color. .. and use the colour palette panel
that appears to set the border colour. Note that if any selected notes do not already
have a border, a one-pixel border will be assigned to them automatically.
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Figure 6.5: A demonstration of the available border thicknesses.
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2. Click on the “Border Color” colour picker in the “Note Style” pane of the Inspec-
tor and choose a colour from the popover that appears. For a custom colour, click

»

on “Show Colors...” at the bottom of the popover to bring up the full colour

palette panel.
To remove the colour from the border, do one of the following:

1. Choose Format » Colors » Clear Border Color.

2. Click on the “Border Color” colour picker in the “Note Style” pane of the Inspec-
tor and choose the white square with the diagonal red line through it in the popover
that appears.

Notes with borders that do not have any specific colour applied will use the default
colour set in the respective Preferences (Appendix A) tab. If there is no default colour
set (you have chosen the “no colour” square with the red diagonal bar through it in the
colour picker), then the default text colour for the document will be used.

If a border colour is added to a note that does not already have a border, the default
one-pixel border style will be applied automatically.

Changing Border Styles

Black one pixel border Orange three pixel border
Cl'he default Rounded style) The default Rounded style.
Square Square

Jagged Jagged

Figure 6.6: The four available border styles.

To change the style of the border, select the items you wish to affect, then do one of
the following:
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1. Use the Format »- Border » sub-menu to select from one of the four available op-
tions:

¢ Rounded (this is the default).
< Square.

4 Jagged.

4 or Cloud.

This sub-menu is also available from the right-click contextual menu.

2. Use the “Style” drop-down menu in the “Note Style” tab of the Inspector to select
from one of the four options listed above.

The default border style for notes and shapes can be changed in the application Prefer-
ences (Appendix A).

6.2.5 Applying Fill Colour to Notes & Shapes
As with text colour (subsection 6.2.3), background fill can be applied to individual notes
and shapes.

To apply a background fill, first select the items you wish to affect, then do one of the
following:

< Choose Format »- Colors » Change Fill Color... ({38 C) This will bring up the colour
palette, from which you can choose the new fill colour.

< Click on the “Fill Color” colour picker in the “Note Style” pane of the Inspector.
This will call up a popover with a selection of colours from which to choose, or if

b

you want a custom colour, click on “Show Colors. ..~ at the bottom of the popover

to bring up the full colour palette panel.
To clear the fill colour from notes so that they use the default, do one of the following:

4 Choose Format » Colors » Clear Fill Color.

< Click on the “Fill Color” colour picker in the “Note Style” pane of the Inspector
and choose the white square with the diagonal red line through it in the popover
that appears.

Notes and shapes can have a default background fill supplied. To set the application
default, use the “New Notes” or “New Shapes” preference tabs (Appendix A).
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6.2.6 Fading Notes

Individual notes and shapes can be faded to reduce their visual intensity on the board.
This is accomplished by blending the text and shape of the note into the background.
As shown (2?), (a) connections among faded notes will follow suit, while (b) connections
that join up with any fully visible note will remain clearly visible.
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Figure 6.7: The notes in the middle have been faded.

When background shapes are faded, all overlapping items will appear faded as well,
making it easy to block out entire groups. This will only impact items within shapes
so long as they remain there. If they are dragged off of the shape they will immediately
return to full visibility.

To toggle whether the selected notes or shapes are faded, use Notes » Fade or \&F.
Alternatively, tick the “Faded” checkbox in the “Note Style” inspector pane.

6.3 Note Style Presets

Style presets provide a simple way to store and reuse multiple appearance settings on
notes and shapes. When you create a new document, a few useful defaults will be pro-
vided for you. These can be deleted if you wish, or changed to act in a different way.
There are a few important things to be aware of:

< Styles can be best thought of as “macros” or format brushes. They are a set of ap-
pearance characteristics that can be applied to selected notes or shapes, and once
you do so they are no longer connected to one another. This may seem obvious,
but to some who are used to stylesheets in word processors, where changing the
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style itself will automatically change everything in the document assigned to it, it
is worth mentioning. Changing a style after it has been used will never go through
and change the appearance of pre-existing notes. It will only change how it func-
tions going forward.

< Styles are document specific. Each document you create will likely have its own
specific formatting needs. You can freely change and delete styles from this menu
without fear of changing other documents. If you would like to import styles from
another document you’ve already created, a convenient tool has been provided for
doing so: Format » Note Style » Import Note Styles....

You can change these default styles in “General” Preferences (Appendix A), by
opening a document with the styles you want to use henceforth, and clicking the
Set From Current Document button.

4 As you might have already picked up, styles are applicable to both notes and back-
ground shapes. If you use a style that contains characteristics specific only to shapes
(like magnetism), it will simply be ignored by notes. Likewise, shapes will ignore
all settings pertaining to text formatting.

6.3.1 Using Styles

To apply styles to notes or shapes, simply select the items you wish to apply the style to
using whatever method you prefer. Next, either use the Format »- Note Style » Apply Note
Style sub-menu to choose the style, or right-click on any of the selected items to bring
up the contextual menu (in most cases this will be most convenient as the sub-menu is
provided at the top-level of the contextual menu).

6.3.2 Deleting Styles

Styles can be deleted from the Format »- Note Styles »- Delete Note Style » sub-menu. As
mentioned before, this will not impact any notes you’ve already created. It will only
remove the style from the list. If you’ve used that style before, you can always get it back
by selecting a note that used that style in the past, and creating a new style from it.

6.3.3 Creating Styles

Styles are created by selecting the single note or shape you wish to use as a prototype for
the appearance, and then using the Format » Note Styles » New Note Style from Selection
menu command. This will bring up an option panel (2?).

Name The name that you provide will be used in all of the menus.
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New Note Style

Name: |Name of New Style

# Include font size and style
 Include text alignment and indent
 Include text color
™ Include background and border style
[ |Include size
[ | Include faded setting

Include magnetic setting

| Cancel \{ OK J

Figure 6.8: The “New Note Style” panel.

Include font size and style The font size and any characteristics such as bold, under-
score or strikethrough will be saved in the style. The font family cannot be saved,
because Scapple documents only use one font per document.

Cases where ranges of text within the note have been styled will be ignored. This
only applies when the whole note has been set to a format, like italic.

This setting is ignored by shapes.
Include text alignment and indent Text alignment, as set in the Format »- Alignment »

sub-menu will be preserved, as well as the indent level of the text. See Indenting
Within a Stack (subsection 4.5.6).

This setting is ignored by shapes.

Include text color The note’s text colour will be saved in the style.

This setting is ignored by shapes.

Include background and border style Both the background fill and the border type
(including thickness, colour and style) will be saved into the style.

Include size For notes, this will save the width of the note. For shapes, both the width
and the height will be saved. This is off by default.

Include faded setting When Format » Fade has been applied to the selection, it will be
saved. This is off by default.
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Include magnetic setting When Notes » Magnetic has been set for a shape, it will be
saved into the style. This setting is ignored by notes.

6.3.4 Updating and Renaming Styles
Changing the formatting stored in the style, as well as its name are both done in the same
way:

1. Select a note that represents what you would like the style to be changed to (making
a new temporary note if necessary).

Alternatively, if you just wish to rename the style, you should select a note that has
identical formatting (again, making a temporary note and applying the style first,
if necessary).

2. Use the Format » Note Style » Redefine Notes Style from Selection... menu com-
mand.

3. The same panel used to create new styles will be presented (22). If all you wish to
do is rename the style, type in the new name and click the OK button. You can also
modify the scope of what the style changes, if you wish.

6.3.5 Importing Styles

Styles can be imported from existing Scapple documents. By default, doing so will not
update or overwrite any of the existing styles in your document, even if they share the
same name. If two styles share a name, they will generate duplicate entries in the menu.
See the prior section for renaming styles.

To import styles from another existing Scapple document:

1. In the document you wish to import the styles to, use the Format» Note
Style » Import Note Styles... menu command.

2. This will bring up a file chooser. Locate the Scapple document you wish to import
the styles from, and click the Open button.

If you wish to completely overwrite the existing styles in the document with the
imported ones, then confirm the option, “Overwrite existing note styles with im-
ported styles”. You will be asked for confirmation of doing this after clicking the
Open button.
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6.3.6 Adding Keyboard Shortcuts to Styles
For styles that you use frequently, you may wish to add a keyboard shortcut to them. To

do this, you will need to use the Mac OS X keyboard tool for doing so:

1.

Use the “Apple” menu at the top left corner of your screen and select “System
Preferences...”.

Click on the “Keyboard” icon, and then select the “Keyboard Shortcuts” tab within
that pane.

. Select “Application Shortcuts” from the left sidebar.
. Below the right-hand list, click the + button.
. Supply “Scapple” as the target application.

. In the “Menu Title” field, type in the precise name of the preset you wish to use.

All punctuation and letter case must be identical. For this to work, the style name
must be unique.

Click into the “Keyboard Shortcut” field and press all of the keys and modifiers
you wish to use for your shortcut.

Tips For Choosing Shortcuts: Scapple has a lot of shortcuts already defined within
it. To avoid conflicts, using shortcuts that use unusual modifier combinations is best.
Control by itself is never used, and Control with Shift is also very rarely used by Mac
programs.
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Navigation

There are several convenient ways of getting around in a Scapple document, which will
become more useful once the board grows to be larger than your screen can comfortably
display.

QuickZoom (z) QuickZoom acts a bit like View » Zoom to Fit, but only while the “z”
key is held down. When the key is released, the zoom will snap back to its original
level, with the location you are pointing at with your mouse scrolled into view.

So long as the key is held down you can manipulate existing notes, moving them
around and drawing connections between them.

Drag-Scrolling If you’ve ever used an illustration or photo manipulation program, you
may be used to holding down the spacebar and holding down the left mouse button
to drag the canvas around. You’ll be pleased to know that this works in Scapple as
well.

Option-Zooming If the Option key is held down, the scroll-wheel on your mouse (or
equivalent gesture on the trackpad) will zoom the view in and out.

Arrow Key Selection When movement mode (subsection 4.2.4) (press M to toggle) is
disabled, the four arrow keys on your keyboard will jump from one note to the
next where possible.

Searching It’s one of those common-sense things that almost does not require mention,
but using the standard Edit » Find » Find. .. (8F) command to search for a key phrase
can also be used for navigation. Consider that you can create notes strictly to serve
as “anchors”, or titles, around larger clusters in the board. In a very large board
with several such anchors, if you give them all a common prefix, the “Find Next”
shortcut, #G, could come in handy for quickly jumping from one cluster to the
next. Read more about Searching in Scapple (chapter 8).
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Searching in Deapple

As your Scapple documents grow larger, finding text you have written will become more
important, especially if the board is much larger than the screen can legibly show. The
facility for finding text will be familiar to anyone who has used a text editor before. You
can use the basic Edit » Find » Find... (3F) panel (2?) to type in the word or phrase you are
looking for, step through search results, and make incremental or global replacements.

e OO0 Find
Find: | Q- Lost ideas L Next |
Replace: | Q- | Previous J
Replace All Scope Find Options

. \ Replace J

(s) All Notes # Ignore Case
| Repl & Find |
() Selected Notes [ Contains SR acesinCe

| Replace All |

Figure 8.1: The standard text find panel.

When text is located, it will briefly flash yellow to help draw the eye to it, and then it
will be highlighted for editing. If you used the Return key to initiate the find, the panel
will be dismissed and you will be placed in editing mode with the phrase selected for
you. When the text you are searching for is located off-screen, Scapple will automatically
scroll the board so that the match is displayed.

It is possible to continue incrementally searching through the document even with the
Find panel closed, with Edit» Find » Find Next (3G), or in the opposite direction with
Edit » Find » Find Previous ({*$G).

Finding Other Instances of Selected Text: If you have a word or phrase you would
like to search for already selected, there is no need to copy it, open the Find panel

60



61

and paste it into the search field. Simply hit & E to load the phrase into the Find panel
silently, and then $G to locate the next instance.

The Find panel contains the following options:

Replace All Scope When using the Replace All button, the available options here will
determine the scope used for the replace. “All Notes” is the default. Every match
will be changed to what is typed into the “Replace” field. If “Selected Notes” is en-
abled, then only those notes you have selected will be considered for replacement.

Find Options Disable “Ignore Case” if you require case-sensitive searching. The drop-
down menu below this option contains four options:

< Contains: this is the default. Searches will match even partial phrases. So
searching for “stal” may return “stalwart” as well as “stall”. Only the portion
that matches will be selected.

& Starts With: the phrase will only match if the word starts with the text typed
into the search field.

& Whole Word: use this option to avoid cases where the phrase might exist as a
component of other words.

& Ends With: the phrase will only match if the word ends with the text typed
into the search field.

The action buttons along the left are as follows:

< Next: finds the next instance of the text in the search field.
& Previous: returns the previous match.
< Replace: replaces the currently selected text and then waits for your command.

< Replace & Find: replaces the currently selected text and automatically jumps to the
next search result.

< Replace All: replaces every instance of the search text with the contents of the
“Replace” field (even if it is empty), within the selected replace all scope.



Chapter 9

Import, Exporting & Printing

Scapple makes it easy to bring in existing notes and to export your work for use in other
applications or for sharing with other people.

9.1 Getting Work Into Scapple

Bringing existing notes and files into Scapple is all done using drag and drop—there is no
dedicated “Import” menu.

@.1.1 Importing Existing Notes
Scapple can read the following text file types:

< .txt

$ .rtfand .rtfd
4 .doc

4 .docx

4 .odt

To import text files of these types, simply drag them from the the Finder and drop
them onto your Scapple document.

< If you drop multiple files, they will be added to the document in a stack.

< If you import a single file, you will be asked if you wish to split it into multiple
notes. If you tick the “Split into multiple notes separated by:” option, you can
then tell Scapple which characters should be sought as representing the division
between notes. For instance, entering two return characters here (which is the
default) will cause Scapple to go through the document and split off new notes
wherever it encounters an empty line.
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Just the Text, Ma’am: Note that only the text (with basic formatting) is imported—
images, tables and suchlike will not be retained.

It is also possible to drag in selections of text from most word processors. Simply select
some text in Scrivener, Microsoft Word, Pages or TextEdit and drag it directly onto your
Scapple document.

?.1.2 Importing Images

Importing images works exactly the same way as importing text files—all you need to do
is drag image files from the Finder onto your Scapple document. Their default width will
conform to that supplied in the preferences (Appendix A). Images, like shapes, can be
resized from any angle, and they will always retain their original aspect ratio.

9.1.3 Adding MathType Equations

If you have MathType (from Design Science'), you can easily add equations to Scapple
and edit them. If MathType is installed, you will see Edit »- Insert MathType Equation. ..
added to the menu system. Selecting this will launch MathType, allowing you to create
an equation. When you close the equation editor window in MathType, the equation
will appear in Scapple. You can then double-click on the equation to launch MathType
again and edit the equation.

Both images and equations are treated as normal notes for most purposes. They can be
styled and connected to other notes.

9.2 Getting Work Out of Scapple

There are several ways to get your work out of Scapple and into other programs. The
File » Export » sub-menu is the most obvious, with the most widely-useful export format
perhaps being PDF, but these are far from the only choices.

?2.2.1 The Order of Things

Before exploring the export possibilities, an important note on exporting to text formats
is in order. Scapple is at its most fundamental level a freeform application: notes can
be written anywhere; connections can be made all over the place, forming loopy circles
and Mabius strips. There is thus no logical order of notes for Scapple to walk through
when exporting to linear formats such as single text files. Neither is there any inherent
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hierarchy that Scapple can use as a basis for working out the best order in which to export
notes.

As a result, Scapple can only make educated guesses at how to best order the notes
when exporting to linear formats. (Imagine seven notes connected in a circle, another
seven notes forming another circle nearby, with two of the notes from each circle con-
nected to one another. Only a human could take these notes and lay them out in a mean-
ingful linear order, basing the new arrangement on the content of the notes—something
Scapple, as an uncomprehending agglomeration of zeroes and ones, has no chance of
achieving.) Scapple makes its educated guess as follows:

& It goes through the notes from left-to-right, top-to-bottom (or right-to-left if that is
the writing direction of the document).

< Whenever it comes to a note that is connected to another note, it walks through all
of the connections.

4 If two or more notes are connected to a note, it starts with the one that is nearest.

4 If a note is connected to more than one other note, it is only included the first time
it is encountered in this traversal process.

< Once Scapple finds no more connections in the current cluster, it continues scan-
ning across the document.

< In text file formats that support hierarchy, such as OPML, background shapes be-
come enclosing groups; in other text formats, they are ignored.

For simple arrangements of notes, this traversal process can work very well. For more
complicated arrangements, however—even moderately complicated ones—you may find
that the order of the notes in the exported text file is not at all what you intended—and
Scapple sadly has no access to your intentions.

Often, therefore, it may be better to export the document to PDF format and copy
and paste the notes from the PDF document into a text document in the order you re-
quire. For instance, you could import the PDF file into Scrivener, have a text document
open alongside it in a split view, and copy and paste between the two. Read more about
Integration with Scrivener (section 9.5).

9.2.2 Export Formats

Scapple can export your work to files, using the formats described in Available Export
Formats (Table 9.1):
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Table 9.1: Available Export Formats

Format Uses

PDF Perhaps the most useful format, since it can be
opened almost anywhere, shows the document
exactly as it appears in Scapple, and allows you
to select and copy the text of notes.

PNG Usetul if you want to produce a simple image

Plain Text (.txt)

Rich Text (.rtf)

Rich Text with Attachments (.rtfd)

Plain Text List (.txt)

Outline Markup (.opml)

file from your Scapple document.

Produces a simple plain text file that can be
opened in any text editor. You can choose how
the notes are separated.

Produces a rich text file that can be opened in
most word processors (including Microsoft
Word). You can choose how the notes are
separated. Note that images are not included
when exporting to the RTF format.

Produces a rich text file that includes images.
You can choose how the notes are separated.
RTEFD files can be opened by most Mac text
programs, including Pages and TextEdit.
(Microsoft Word cannot open RTFD files.)
Produces a simple plain text file with each note
separated by a single line break. This format is
the best one to choose if you wish to open the
file in a spreadsheet such as Numbers or
Microsoft Excel.

Produces a file in the Outliner Processing
Markup Language format, which can be
opened by many outlining programs (such as
OmniOutliner). Background shapes are
exported as groups.
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As explained in The Order of Things (subsection 9.2.1), Scapple can only make an
educated guess at the best way to order the notes when exporting to linear text files.
This means that for all formats except PDF and PNG, you may need to rearrange the
notes in an external editor to achieve the order you want.

To export to one of these formats, choose the appropriate option from the File » Export
menu. For most formats, you can choose whether to export all notes or only those that
are currently selected.

The options available for each format are detailed below.

Export Format Options

When you choose one of the formats available in the File » Export menu, a Save panel
appears, allowing you to choose where on your hard disk the exported file should be
saved. Depending on the format you selected, the Save panel may also contain options
that allow you to customise the appearance of the exported file, or to choose what is

included.

PDF File » Export » PDF... ({+$8E)

Draw background and use default text color If ticked, the PDF document will
look exactly the same as your Scapple document, using the same background
and text colour; if deselected, the PDF will not include a background colour
(and will thus appear white) and will use black text as the default (although
notes that have had their text colour changed specifically will remain in that
colour).

Draw faded notes at full opacity If ticked, the “Fade” setting that can be applied
to notes is ignored in the PDF file and all notes will appear fully opaque.

PNG File » Export » PNG...

There are no options available when exporting to the PNG format. The PNG
created will be a faithful representation of how your Scapple document looks on-
screen. (If you require a higher resolution, it is better to export to PDF.)

Plain Text File » Export » Plain Text (.ixt)...

Export selected notes only If ticked, only the notes that are currently selected in
your Scapple document will be included in the generated file; otherwise, all
notes are included.
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If no extension is provided, use “.txt” If ticked, the “.txt” extension will be ap-
pended to the file name, and even if you type a custom file extension, OS
X will prompt you to use “.txt” instead. Deselect this if you wish to export
using a different file extension (e.g. “.md”).

Separator Notes in the exported file will be separated by whatever characters you
enter in the “Separator” text field. If you leave the field blank, notes will be
separated by an empty line.

Rich Text Formats File » Export » Rich Text (.rff)... and File » Export » Rich Text (.rifd). ..

Export selected notes only If ticked, only the notes that are currently selected in
your Scapple document will be included in the generated file; otherwise, all
notes are included.

Separator Notes in the exported file will be separated by whatever characters you
enter in the “Separator” text field. If you leave the field blank, notes will be
separated by an empty line.

Plain Text List File » Export » Plain Text list (.ixt)...

Export selected notes only If ticked, only the notes that are currently selected in
your Scapple document will be included in the generated file; otherwise, all
notes are included.

Outline Markup File » Export » Outline Markup (.opml)...

Export selected notes only If ticked, only the notes that are currently selected in
your Scapple document will be included in the generated file; otherwise, all
notes are included.

Create notes field When this option is selected, the full text of each Scapple note
will be saved as an OPML “note”. The first few characters (fifty, or up to the
first line break, whichever is the shortest) will be used for the “heading” of the
outline element. When this option is deselected the entire text of the Scapple
note will be saved into the element headline. This produces a more compati-
ble result, as not all OPML readers will detect a note field as well as a headline
field. If you are unsure, just leave this option deselected, or experiment with
which option works best with whichever outlining application you use.

Exporting images
If you have dragged images into your Scapple document, you can export them by select-
ing File » Export » Images... Ticking “Export selected notes only” in the export panel
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will cause only the images that are selected in your Scapple document to be exported.
Otherwise, all images in the document will be exported. (This option is unavailable if
the Scapple document does not contain any images.)

9.2.3 Copy and Paste

Along with dragging files into Scapple and using File » Export to get your ideas out, you
can also use copy and paste to bring notes in and out.

< Bringing work into Scapple using copy and paste:

1. Select some text in another program and copy 1t (3£C or Edit » Copy in most
applications).

2. In Scapple, right-click where you want the text placed and select “Paste” from
the contextual menu. (Alternatively, just hit 88V or use Edit » Paste, and the
note will appear somewhere in the top-centre of the view.)

3. If you wish to split the imported note into several smaller notes, double-click
on it to edit it, place the cursor where you would like to split it, and use the
Notes » Split (88 K) option.

This is a great way of quickly bringing in text from other open applications.

4 Getting work out of Scapple using copy and paste:

1. In Scapple, select the notes you wish to take to another program.
2. Hit $C or go to Edit » Copy (or use “Copy” in the contextual menu).

3. Open the other program and paste at the location you would like the copied
notes to appear (in most Mac programs, the “Paste” option appears in the
Edit menu and has the keyboard shortcut V). The text of the notes will be
pasted with an empty line between each note. This will work in any program
that can read either plain or rich text from the OS X pasteboard, including
Scrivener, Microsoft Word, Pages, Mail, TextEdit and most other applications
that can edit text. (If only a single image note is copied, it can also be pasted
into image programs such as Preview.)

.3 Printing Scapple Boards

To print your Scapple document, select File »- Print. ... This will bring up OS X’s standard
print panel. Here, along with the usual options such as the number of copies that should
be printed and which printer to use, you will find several Scapple-specific options that
allow you to determine how your document should be printed.
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If you don’t see any options, be sure to click on the “Show Details” button (22).
This will expand the print panel so that the preview is displayed on the left and the
printing options are shown on the right.

Printer: | A Officejet Pro 8500 A910 :

s

Presets: | Default Settings

Copies: |1 | Black & White [ | Two-Sided
< Pages: (o) All
JFrom: |1 to: |1
Y Paper Size: | A4 4| 8.27 by 11.69 inches

Orientation: I’i\’ T Scale: 100 %

Scapple :

| Print Header and Footer
| Print Background
| Print Border Guides

lofl
™ Scale to Fit One Page

? PDF v Hide Details Cancel \ Print \

Figure 9.1: Standard Mac OS X print panel, showing Scapple settings in the lower-right.

On the top-left, you’ll see all the options that you would expect to find in any
program—the paper size and orientation, the scale to use, and so on.

Below that, if “Scapple” is selected in the pop-up button that appears just over half-way
down the printing panel (it should be selected by default), you will see four extra options.
These are described below.

Print Header and Footer If selected, a basic header and footer will be added to printed
pages, showing the name of the document, the date and time, and the page number.

Print Background If selected, the background of the document is printed. In general,
unless you want a full-colour print-out that includes the background colour or
texture, it is best to leave this deselected when printing.

Print Border Guides If selected, a dotted line is printed to show where the page borders
begin. This is most useful when “Scale to Fit One Page” is turned off so that the
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document is printed across multiple pages. The dotted lines then serve to show you
where to cut if you want to tape together a large print-out of your document.

Scale to Fit One Page If selected, the document will be printed on a single page (the
scale percentage is ignored in this case). If deselected, the document will be printed
across as many pages as are required to accommodate the current scale percentage
(as set in the text field next to the Orientation setting).

2.3.1 Working with Printed Page Guides

When working for print as your output, you may frequently have need for a display
which shows you where one sheet of paper will end and another will begin. The
View » Page Guides menu command will toggle the visibility of this grid, making it easy
to avoid page breaks while working.

The page grid will be drawn in accordance with the document’s print settings (estab-
lished in File/Page Setup...). It should be noted that the non-printable area of a page will
not be depicted by the grid. This can mean that notes will appear further from the edge
of the paper, than they might from the grid line.

.4 Transferring Notes Between Scapple Boards

Transferring notes between different Scapple documents is easy: you can either copy and
paste them or drag them across.

2.4.1 Using Copy and Paste to Transfer Notes Between Scapple
Documents

1. Select the notes you wish to transfer to another Scapple document.

2. Select Edit » Copy or hit $8C. (Alternatively, if you wish to remove them from the
original document, use Edit » Cut or X.)

3. Open the other Scapple document.

4. Right-click on the location you would like the notes to appear and select “Paste”
from the contextual menu. (Alternatively, use Edit » Paste or just hit 8V to have
the notes pasted somewhere central in the viewed area.)

9.4.2 Dragging Notes Between Scapple Documents
1. Select the notes you wish to transfer to another Scapple document.

2. Ensure the other Scapple document is open alongside the original.
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3. Drag the selected notes from the original across to the other document, releasing
the mouse button at the location you wish the notes to be placed.

4. If you wish to remove the notes from the original document, return to that docu-
ment and hit the Delete key.

A Note on Font Sizes: When transferring notes to another Scapple document, all
connections between the dragged notes are maintained and the notes retain all of
their appearance options. However, if the two documents use different fonts, the
transferred notes may not be optimally sized since they were created using a font
with different metrics, and overlapping may occur. Stacks can be reset by select the
entire stack and using Notes » Stack (88°).

3.5 Integration with Scrivener

As you’d expect, given that Scrivener is our writing software package, it’s easy to move
notes between Scapple and Scrivener. The general assumption is that Scapple is the place
you hash out ideas in their very early stages, and when Scapple’s toolset has helped you
work out where you want to go, you take those ideas into Scrivener for further develop-
ment. But it’s easy enough to go the other way, too, and bring notes from Scrivener into
Scapple so that you can play with them in a more freeform environment.

Here are some simple ways of incorporating Scapple into your Scrivener workflow (or
vice versa).

2.5.1 Dragging Ideas From Scrivener Into Scapple

A separate note will be created in Scapple for each dragged document. The created notes
will contain the titles and synopses of the Scrivener documents that were dragged in, and
if dragging from a freeform corkboard, they will be placed in the same relative positions
as the cards in Scrivener. Items can be dragged from the Binder sidebar, Outliner or
Corkboard editor views in the order that they appear in Scrivener.

Dragging From a Freeform Corkboard

1. In Scrivener, select the folder containing the notes you want to import in the

binder.

2. Switch to corkboard mode, so that you see the documents as cards on the cork-

board.
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3. Switch the corkboard to freeform mode (using the segmented control in the footer

bar).
4. In the freeform corkboard, select the documents you wish to import into Scapple.

5. Drag the documents from Scrivener’s freeform corkboard into your Scapple docu-
ment.

92.5.2 Dragging Notes From Scapple Into Scrivener
1. In Scapple, select the notes you wish to import into Scrivener.

2. Drag the notes into Scrivener’s binder or Scrivener’s freeform corkboard (notes can
only be dragged into the corkboard if it is in freeform mode).

If notes are dragged into the freeform corkboard, they will maintain the same rela-
tive positions they had in Scapple. When dragged into the binder, Scapple will make an
educated guess at the best order to use (see The Order of Things (subsection 9.2.1)). For-
tunately, it’s very easy to rearrange items in Scrivener’s binder, so if the notes aren’t in the
order you would like, you can simply drag them into the correct order once imported.

2.5.3 Importing Your Scapple Document Into Scrivener As a PDF

If you just want to reference the network of ideas you have created in Scapple while
writing in Scrivener, a really good approach is to generate a PDF file and bring that into
Scrivener, as follows:

1. In Scapple, go to File » Export »- PDF... ({+&E) and save the PDF file to disk.

2. Locate the PDF file in the Finder and drag it into Scrivener’s binder (remember
that you cannot place PDF files into Scrivener’s Draft folder, though).

Alternatively:

1. Ensure that Scrivener is open and that the project you wish to import your Scapple
notes into is the frontmost project.

2. In Scapple, go to File » Print... (P) to bring up the Print panel.

3. In the lower-left of the Print panel, click on the “PDF” button and select “Save
PDF to Scrivener” from the menu that appears.
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A PDF version of your Scapple document will be placed as the last item in the Research
folder of the frontmost Scrivener project. (Note that the “Save PDF to Scrivener” service
is not available in the Mac App Store version of Scrivener, owing to App Store rules.)

Once your PDF file is imported into Scrivener, you can split the editor and refer to
your Scapple PDF alongside your writing.

2.5.4 Importing Your Scapple Document Into Scrivener As-Is

Instead of importing your Scapple document into Scrivener as a static PDF file, you can
simply drag the .scap file itself into Scrivener’s binder (placing it anywhere except in the
Draft folder). On OS X 10.7 and above, you can then view the Scapple document as
a Quick Look preview inside Scrivener (on 10.6 it will appear as a linked file, because
the Quick Look preview is not available on systems earlier than 10.7). Then, use the
“Open in External Editor” feature of Scrivener to open and edit the version of the Scapple
document that is now stored inside your Scrivener project.
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The Inspector

The Inspector allows you to customise the appearance of individual notes and back-
ground shapes as well as of the document as a whole. It comprises two panes: “New
Note” and “Document”, which are detailed below. Many of the options available in the
Inspector are also available in the Format menu, although the options in the “Document”
pane appear nowhere else.

Note that all options in the inspector will be disabled (greyed out) if there are no
documents open. Individual options may be disabled depending on which objects are
currently selected in the frontmost document. For instance, all options in the “Note
Style” pane are disabled if no notes are selected, and options that are not applicable to
background shapes are disabled when background shapes are selected.

10.1 Note Style

The “Note Style” pane provides options for editing the appearance of notes and back-
ground shapes.

Text Style Allows you to apply bold, italic, underline or strike-through formatting to
the text of a note. If whole notes are selected, the formatting is applied to the entire
text. If a range of text is selected within a note while it is being edited, the format-
ting is applied only to the selected range. These options are also available in the
Format »- Font » sub-menu (and can be applied using standard keyboard shortcuts).

Font Size Determines the font size of selected notes. (The default font size for new notes
can be set via the Preferences. The font face itself is set via the “Document” pane of
the Inspector, since Scapple documents are limited to using a single font face.) The
font size can also be increased or decreased using the 8¢+ and 88 - keyboard shortcuts
or the Format » Font » sub-menu.

Text Color Determines the text colour of selected notes. The text colour can also be
changed via the Format » Colors » sub-menu. (The text colour used by notes that
do not have a colour set explicitly can be set via the “Document” pane of the In-
spector. Thus, for instance, if you want a blue document background with white
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Figure 10.1: The “Note Style” tab of the Inspector.

text for all notes, it would be most efficient to set this via the “Document” pane of
the Inspector, rather than by using “Text Color” in the “Note Style” pane, which
is better for applying a different colour to the standard note text colour.)

Alignment Determines the text alignment of selected notes (left, centred, right or jus-
tified). These options are also available via the Format » Alignment » sub-menu.
(The default alignment for new notes can be set via the Preferences.)

Fill Color Determines the fill colour of selected notes. The fill colour can also be
changed via the Format » Colors » sub-menu. (The default fill colour for new notes
can be set via the Preferences.)

Faded Determines whether or not the selected notes should be semi-transparent. Also
available in the Format menu. (The exact level of transparency can be set via the
Preferences.)

Border Color Determines the border colour of selected notes. The border colour can
also be changed via the Format » Colors » sub-menu. (The default border colour
for new notes can be set via the Preferences.)
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(Border) Thickness Determines how thick the borders of selected notes are. The border
thickness can also be changed via the Format » Border » sub-menu. (The default
border thickness for new notes can be set via the Preferences.)

(Border) Style Determines the style of border used by the selected notes (“round”,
“square”, “jagged” or “cloud”). The border style can also be set via the For-
mat » Border» sub-menu. (The default border style for new notes can be set via

the Preferences.)

Shadow Determines whether a shadow should be drawn around selected notes. This can
also be set via the Format menu. (Whether or not new notes have a shadow can be
set via the Preferences.)

Magnetic (Only available for background shapes) Determines whether or not selected
background shapes are “magnetic”. If a background shape is magnetic, then when
it is moved, any notes that overlap it are also moved. If it is not magnetic, then
when it is moved, overlapping notes remain where they are. This option is also
available in the “Notes” menu, and the default setting for new background shapes
can be set set via the Preferences.

10.2 Document

The “Document” tab provides options for determining the general appearance of the
document (and for setting the default appearance of new documents).

10.2.1 Background Color

Clicking on the colour well brings up the colour palette, allowing you to set the back-
ground colour of the document. The Use Default button resets the background to Scap-
ple’s default off-white.

Alternatively, click on Choose Texture to select an image file from disk to be used as a
background texture. Background texture images are tiled (that is, repeated over and over),
so you should only use images with repeating patterns. Images selected for use should be
small to avoid performance issues—we recommend nothing over 512x512 pixels, but a
small file size is equally important. There are many great tiling textures available on the
internet.

10.2.2 Text Appearance Options

Default Color Clicking on the colour well brings up the colour palette, allowing you to
set the default colour of the text in new and existing notes. The colour set here will
be used by all notes in the document that have not had a text colour set explicitly



10.2. DOCUMENT 77

8 00 Inspector

| Note Style

Background Color
[ 9| | useDefault |

| Choose Texture... |

Text Appearance

Default Color:

| IN Clear

Font:

| Helvetica a

Writing Direction:

| Left to Right s

Set As Defaults

Figure 10.2: The “Document” tab of the Inspector.

via the “Note Style” pane or Format menu. Clicking on “Clear” will get rid of
the default text colour, in which case the default text of notes will be whatever
contrasts best with the current document background colour.

This setting is also used for the colour of connecting lines between notes.

Font Determines the font face of notes in the current document. Each Scapple docu-
ment can only use a single font face (although the text size can vary between notes,
and text can be formatted using bold, italics, underline and strikethrough). In gen-
eral, it’s best to choose the font face when you first create the document rather than
much later when you have a complicated arrangement of notes, because different
font faces have slightly different metrics, and changing the font can cause notes to
get resized and shift around.

Writing Direction Determines whether text in the document is left-to-right or right-to-
left. This also determines whether stacks are defined by the left or right edges of
notes, and the order in which notes are processed when exporting to text formats.

Set As Defaults Clicking the “Set As Defaults” button causes all of the settings in the
“Document” pane of the Inspector to be set as the defaults for new documents.
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Appendix A

Preferenees

Application settings allow you to make global changes to the way the software works.
Open the Preferences panel by selecting the Scapple »- Preference. .. menu command.

The panel has three tabs: “General”, “New Notes” and “New Shapes”. The “General”
tab allows you to determine a variety of application-wide behaviours, while the “New
Notes” and “New Shapes” tabs allow you to set up the default appearance and behaviour
of new notes and background shapes.

Adjusting Defaults for Documents: To set the default board colour, text colour,
font and writing direction for new documents, use the “Set As Defaults” button in the
“Document” tab of the Inspector. To avoid clutter and keep settings to a minimum,
these options are not duplicated. Likewise, a number of options in the interface are
inherently carried over as defaults for newly-created documents. For instance, when
you turn spell-checking on or off via the Edit » Spelling and Grammar» sub-menu,
the setting you choose will be used as the default for new documents.

A.1l Generdl

Options available in the “General” Preferences tab are as follows:

Return ends editing If selected, when editing a note, hitting Return will cause editing
to end and the focus to return to the main Scapple view. If this is not selected, then
Return will add carriage returns to your notes, and you will need to use the Esc or
Enter keys to end editing.

Return creates new notes If selected, when the main Scapple view has the focus (i.e.
when you are not editing a note), hitting Return will create a new note, exactly as
hitting \“Return does. If this is deselected, then hitting Return will begin editing
the currently-selected note.

Use selected note style for new notes When ticked, if notes are selected (highlighted
with a selection border) when you create a new note, the new note will look the
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Preferences
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Figure A.1: The “General” tab.

same as the first-selected note in the selection. For instance, if you select a note
that has a yellow background and a jagged border, then create a new note, the new
note will likewise have a yellow background and a jagged border. If this option is
deselected, new notes always use the default appearance options as set in the “New
Notes” pane of the Preferences.

Auto-size notes If ticked, when you finish editing a note, if the note is composed of
one or more lines that are shorter than the default note width (as determined in
the “New Notes” Preferences tab), the note width will be adjusted to snugly fit the
text.

Faded Transparency This slider determines the visibility of notes that are set to be
faded. If the slider is all the way to the left, the note will be almost entirely opaque;
if all the way to the right, the note will be nearly invisible.

Default note styles for new documents Allows you to determine the set of note styles
that appear in the Format » Note Style » Apply Note Style menu for new documents.
Clicking Set From Current Document will take the note styles of the frontmost Scap-
ple document and archive them for use in new documents. This set of note styles
(as they were at the time this button was clicked) will then appear in the note style
menu in new documents created using File » New.... Clicking Reset to Defaults
will reset the note styles used for new documents to those that are provided with
Scapple by default.
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Automatically check for updates [Direct-Sale Only] If this is checked, whenever
Scapple is launched it will check the website to see if there is a newer version avail-
able and, if so, will ask you if you want to update. Note that if you do not have
this checked, you can still check for updates by choosing the Scapple » Check for
Updates... menu command.

The drop-down menu beneath this option governs how frequently Scapple will
check for new versions. If you want to stay on top of the latest updates, “Daily”
is generally good enough, but if updating frequently is disruptive to your work
habits, you can set this to check by week or month.

A.2 New Notes

The “New Notes” pane determines the default appearance of newly-created notes. After
notes have been created, their appearance can be edited using the Inspector or Format
menu.

8 0 0 Preferences

| General

Default text: New Note
Default font size: 12 pt =)
Default width: 200 px | |7

Default alignment: EEEE

[_J Fill Color Y

Border: | No Border 4
Border Style: | Cloud o
Border Color: ]

[ | Shadow

Default document appearance options can be set using the
"Set As Default" button in the "Document” pane of the
Inspector.

Figure A.2: The “New Notes” tab.

Default text Determines the placeholder text that will appear in newly-created notes.
This can be left empty if you do not wish new notes to contain placeholder text.

Default font size Determines the default font size for new notes. (The font itself is set
in the “Document” pane of the Inspector.)



82 APPENDIX A. PREFERENCES

Default width Determines the width of new notes. (Notes can be resized after they are
created, and if “Auto-size notes” is ticked in the “General” Preferences tab, new
notes may automatically be shrunk to fit.)

Default alignment Determines the default text alignment of new notes. (The alignment
of individual notes can be changed via the Inspector or Format menu after they are
created.)

Fill Color Determines the default fill colour for new notes. (The fill colour of individual
notes can be changed via the Inspector or Format menu after they are created.)

Border Determines the default border thickness for new notes. (The border of individ-
ual notes can be changed via the Inspector or Format menu after they are created.)

Border Style Determines the default border style for new notes. (The border style of
individual notes can be changed via the Inspector or Format menu after they are
created.)

Border Color Determines the default border colour for new notes. (The border colour
of individual notes can be changed via the Inspector or Format menu after they are
created.)

Shadow Determines whether new notes have a shadow or not. (This setting can be
changed for individual notes via the Inspector or Format menu after they have
been created.)

A.3 New Shapes

The “New Shapes” pane determines the default appearance of newly-created background
shapes. After background shapes have been created, their appearance can be edited using
the Inspector or Format menu.

Fill Color Determines the default fill colour for new background shapes. (The fill
colour of individual background shapes can be changed via the Inspector or Format
menu after they are created.)

Border: Determines the default border width for new background shapes. (The border
of individual background shapes can be changed via the Inspector or Format menu
after they are created.)

Border Style Determines the default border style for new background shapes. (The bor-
der style of individual background shapes can be changed via the Inspector or For-
mat menu after they are created.)
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Figure A.3: The “New Shapes” tab.

Border Color Determines the default border colour for new background shapes. (The
border colour of individual background shapes can be changed via the Inspector or
Format menu after they are created.)

Shadow Determines whether new background shapes have a shadow or not. (This set-
ting can be changed for individual background shapes via the Inspector or Format
menu after they have been created.)

Magnetic Determines whether new background shapes are magnetic or not—that is,
whether notes that overlap them are carried along whenever they are moved. (This
setting can be changed for individual background shapes via the Inspector or Notes
menu after they have been created.)



Appendix B

Menus and Key]ooar@l Shortcuts

This appendix will list most of the available menu commands along with their keyboard
shortcuts, a short description of what the command does, and a cross-reference to further
documentation on the feature if one is available. It is thus useful as a topical table of
contents.

B.1 Scapple Menu

The main application menu contains integration tools with other software, application
management, information and preferences.

About Scapple Display the credits and version information.

Preferences (3¢,) Application preferences allow you to alter aspects of how the software
looks and feels. Read Preferences (Appendix A) for more information on what can
be changed.

Registration [Direct-Sale Only] If you are using the demo version of Scapple and de-
cide to purchase it, use this menu command to input the registration serial name
and number and activate the software. Read Registration (section 3.2) for more
information.

If the software is already registered, this will show your serial name for reference.

Check for Updates... [Direct-Sale Only] The software can be set to check for up-
dates automatically in the “General” preference tab (section A.1). If you have dis-
abled this or just wish to check before the next scheduled check, this menu com-
mand will force an update check. When updates are available, you will be walked
through the automatic update process. Read Application Updates (section 3.3) for
more information on this topic.
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Services Services are how different programs on your Mac can communicate with one
another. For example, if you have Scrivener installed, and are editing the text of a
note, you can send a selection of text to Scrivener via this menu.

Quit Scapple (3Q) Quits the software, closing all windows. On Mac OS X 10.7+, win-
dows will normally be saved automatically as they are closed, and re-opened for
you when you start Scapple again. On 10.6, you will be prompted to save any
documents with pending changes.

Quit and Keep (Close) Windows (32:Q) [Mac OS X 10.74+] When holding down the
Option key, this alternate menu command will appear. Whether this displays
“Close” or “Keep” windows depends upon your system preferences to reopen
projects that were open on quit, thus allowing you to temporarily override the
default. This will not change your preference; it only impacts the one time you
quit.

B.2 File Menu

Contains commands for managing documents (Scapple boards), as well as moving data
in and out of them via import, export and printing. This section will list the all of the
available commands on Mac OS X 10.7 or greater, marking those that will not appear on
10.6.

New (2N) Immediately creates a new blank Scapple board to work on (section 5.1).
Your work will begin autosaving immediately to a temporary file, on 10.7+4, until
it is given a name and location to be saved to.

Open... (880) Open an existing Scapple board from the disk (section 5.3). You can also
load documents by double-clicking on them in the Finder, or dragging them to the
Scapple icon.

Open Recent > Select from the previous Scapple documents you have worked on.
This is a rotating list, which means that over time older documents may fall off the
list. Additionally the list can at times be wiped with system or software updates. If
you are unsure of where a missing document has gone, read Finding and Locating
Scapple Documents (section 5.6). The number of items listed in this sub-menu is
governed by OS X’s global preference, which can be set in the system “General”
preference pane (“Appearance” on Mac OS X 10.6).
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Close (32W) Immediately closes the current Scapple document, automatically saving
when doing so. With unsaved documents, and on 10.6 in general, you will be
prompted to save each board as necessary. When holding down the Option key,
this menu command will become “Close All”. All open documents will be simul-
taneously closed, though the software will continue running until you quit it.

Save... (88S) On Mac OS X 10.7, this menu command will be named, “Save a Ver-
sion...”. This is fundamentally identical to the action that is taken on 10.8+, the
label has merely been simplified. Read more about autosave and version features in
Using Autosaved Versions of Your Scapple Boards (section 5.4).

On 10.6, autosave is not available and thus neither is versioning. Saving the board
will merely overwrite the old copy on the disk in a standard fashion. Time Ma-
chine, if set up properly, may still record incremental changes by the hour.

Duplicate /Save As... (+8S) On 10.74 this will be labelled as “Duplicate”. It will
create a new copy of the document in a new window which can then be saved to
a new file. On 10.8, holding down the Option key will alternate this command to
“Save As...”, which will work in the traditional fashion.

On 10.6, “Save As...” follows the traditional mechanism for automatically creating
a new copy of the document and saving the changes to it. The original document
will not receive any of the unsaved changed at that point. Moving forward you
will be working in the new document, allowing you to leave a “trail” of revisions

behind you.

Rename... [Mac OS X 10.7+] Allows you to rename the document without closing
it, changing the name in Finder, and then re-opening it.

Move To... [Mac OS X 10.74+] A convenience feature to move the document to a
new location without closing it, moving it in Finder, and then re-opening it from
the new location.

Revert To» [Mac OS X 10.74+] When the word “Edited” appears after the name of
the document in the title bar, this menu will display the last saved version in a sub-
menu. Alternatively you can select File » Revert To »- Browse All Versions. .. to bring
up the Mac’s autosave version interface.

Export» This sub-menu provides a number of different formats that you can use to
export your ideas into a format that is more suitable for working in other programs,
or as a graphic file rendering of the map. On account of Scapple’s freeform design,
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the order in which notes appear must at times be guessed at. There is no internal
order or hierarchy to make use of. That said, clusters of notes connected together
and notes overlapping a background shape together will prefer to stick together, as
well as stacked notes.

Read more about the available formats in Getting Work Out of Scapple (sec-
tion 9.2).

Prevent Editing Toggles a lock on the board so that it can no longer be changed.

Page Setup... (1+88P) Set up the paper size and page settings for printing to either PDF
files or to paper using a printer. This makes no impact on the size of the board
itself, merely how the board will be chopped up into paper sized pieces.

Print... (P) Send the Scapple board to your printer (you can optionally save as a PDF
as well, using the standard Print dialogue). Maps that are larger than a single sheet
of paper can either be scaled to fit, or automatically sliced into paper sized chunks,
so that they can be taped together. Read more about Printing Scapple Boards (sec-
tion 9.3).

B.3 Edit Menu

The “Edit” menu concerns itself primarily with the manipulation of text, but also con-
tains commands for passively working with notes and shapes (e.g. selecting notes, or
finding them). For active manipulation of these, the “Notes” menu is a better bet (sec-
tion B.5).

Undo & Redo (322 /©Z) Undoes or redoes the changes made to the document in the
order they were made. Undo will step backward in the change list, and redo will
return forward. If changes are made after undoing, the redo history will be erased.
Most actions that can be taken in Scapple can be undone.

Editing a note’s text enters an isolated state where undo and redo will only act
upon the edits made to the text. Once you finish editing, the overall undo and redo
history will be returned to seamlessly.

Cut, Copy and Paste (36X /% C [¢2V) Cut, copy and paste act fundamentally as they do
in other applications.
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< When working with notes in a Scapple document, all of the notes in the selec-
tion will be acted upon. You can use these commands within the same board,
or from one board to another.

4 Pasting notes into another text editor will place the text content of the notes,
including any inline formatting if the target editor is compatible with rich
text.

¢ When editing text, the commands work as you would expect them to in any
text editing application.

4 Read Copy and Paste (subsection 9.2.3) for more information on how notes
and text can be copied, cut and pasted.

Delete delete Permanently removes the selected notes or shapes from the board. This
action can be undone.

Arrow Keys Move Notes (M) Toggle between Movement Mode (subsection 4.2.4) and
selection mode. Movement mode lets you “nudge” notes with the keyboard arrows,
while selection mode will attempt to select notes in the direction of the arrow press.
Use the shift key to increase how much distance a note is moved by.

Select All (32A) When editing text, all of the text within the current note will be selected.
Otherwise, all of the notes on the entire board will be selected, even if they are not
currently visible.

Select » This sub-menu provides a number of convenience methods for selecting notes.
Read more about Selecting Notes (subsection 4.2.2) and Selecting Shapes (subsec-
tion 4.4.2).

Notes Stacked Below (Y8 A) Selects the remainder of the notes in the current
stack, starting from the selected note down. If multiple notes within the stack
are initially highlighted, the entire stack will be selected.

Notes Overlapping Selected Shapes (~3A) Applicable only when one or more
background shapes are selected. All notes overlapping these shapes will be
added to the selection. You may also hold down the Option key and click
in the background area of the shape to perform this action. {+\Cclick allows
multiple shapes and their overlapping notes to be incrementally added to the
selection.
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Connected Notes (232 A) All notes directly connected to the currently selected
note(s) will be added to the selection. Consequently, chaining this command
will allow you to incrementally broaden the selection to those note’s connec-
tions, and onward.

Connected Clusters (X188 A) Fully selects all notes directly and indirectly con-
nected to the currently selected note(s). Thus, note “Alpha” connected to
note “Beta” which is in turn connected to note “Gamma” will all be selected
if this command is used on any of the notes.

Invert Selection 8¢8I Flips the selection state for the entire board. All items that were
selected will be removed from the selection, and all items not selected will be added.

Deselect (3¢D) All notes will be deselected. This can also be done by clicking anywhere
on the background, but in cases where a background shape is filling the entire view,
this command will properly deselect everything for you.

Insert MathType Equation... Inserts a MathType image equation as a new note in
the centre of the current view. If MathType is not properly installed, this menu
command will be hidden.

Add/Edit Link. .. (¢6L) Applicable only when editing the text of a note. While editing
text, the menu command will read “Add Link...”. You may then copy and paste
the URL into the provided dialogue box to add a hyperlink to the selected text.

When a link is selected (or even if the cursor is currently within the span of the hy-
perlink), the menu label will read, “Edit Link...”. This will bring up the dialogue
box so you can edit the target URL of it.

Find» Provides general tools for finding text that has been typed into notes. Read
Searching in Scapple (chapter 8) for more on using the search features.

Find... (8F) Brings up the standard “Find” panel. This will locate text that has
been typed into notes, scrolling the view if necessary to locate the note it
resides within. Finding text within a note results in being pulled into editing
mode, so you can start typing or editing the text immediately.
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Find Next (32G) Finds the next occurrence of the last text you searched for, using
the search parameters you have set up in the Find panel. This can be done via
the keyboard shortcut, even when the Find panel is closed.

Find Previous (13 G) As above, only it will seek backward in the text instead of
forward.

Use Selection for Find (32E) Use the currently selected text, or the entire con-
tents of the selected note, as your search term. You could then immediately
use Find Next/Previous, or load the Find panel and refine the search parame-
ters or supply a replacement text.

Jump to Selection (38J) Scrolls the view so that the currently selected text is posi-
tioned in the middle of the window (or as close as possible to it). Useful if you
want to quickly check another area of the board and then passively return to
where you were, without typing or removing the selection.

Spelling and Grammar »  Accesses the standard Mac OS X spell check and grammar
system (for supported languages). The contents of this menu are the same as can be
seen in any standard Mac program, such as TextEdit or Scrivener.

Spell checking must be used in a text editing context only.

Substitutions » [Mac OS X 10.7+] Access to substitutions such as smart quotes and
other symbols.

Transformations » [Mac OS X 10.7+] Access to text utilities for converting text case.

Speech > Access to the text-to-speech synthesis engine supplied by the OS.

Start Dictation [Mac OS X 10.84] For computers capable of recording audio and
making use of the OS X speech-to-text dictation system, this can be used to speak
words aloud and have them turned into editable text.

Special Characters... (X&T) Loads the OS X Unicode character browser. Use this to
insert characters that are not found on your keyboard.

B.4 View Menu

The “View” menu controls how the current Scapple board is displayed, as well as whether
or not the Inspector palette tied to that board is shown.
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Show (Hide) Inspector (\8¢1) The floating Inspector palette holds useful formatting
tools for both selected notes & shapes, as well as for the document itself. This
shortcut toggles its visibility on and off. Read more about the Inspector (chap-
ter 10).

Show (Hide) Footer Bar &/ Toggles the visibility of the Footer Bar, along the bottom
of the window. This will be remember for future boards as well. If you turn off
the footer bar in an existing board, a newly created board will also have its footer
bar disabled. Existing boards will remember what they have been set to.

Page Guides Toggles the visibility of printed page guides (subsection 9.3.1) on the Scap-
ple board background. Using these guides, you can see where one sheet of paper
will end and another will begin, making it easier to avoid situations where notes

straddle a page break.

Actual Size (320) Reverts the current zoom level of the view to the default level. This
can also be done by clicking the Reset button in the Footer Bar.

Zoom To Fit (389) Adjusts the zoom by increasing or decreasing the magnification so
that every note on the map can be seen at once.

Zoom In (X8 UpArrow) Incrementally increase the magnification of the board. The
slider in the Footer Bar can also be used to adjust the scale of the board visually.

Zoom Out (\C¢8DownArrow) Incrementally decreases the magnification of the board.

Zoom To Selection (32*) Works in a fashion similar to View » Zoom to Fit, save that only
those notes that are selected will be fitted into the view.

Zoom To Random (2R) Zooms the view to a random note anywhere on the board.

Enter Full Screen (~8F) [Mac OS X 10.74+] Expands the current window to fill the
entire display, pushing aside the menu bar and the system Dock. This places the
window on its own “Space” in Apple’s Mission Control. Each document must
occupy its own Space.
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QuickZoom (z) On account of how this feature works, it cannot be listed in a menu as
it only works while the keyboard shortcut is depressed. However it is listed here
as it deserves mention with these other features. QuickZoom will act a bit like
View » Zoom to Fit, but only while the shortcut key is held down. When the key
is released, the zoom will snap back to its original level, with the location you are
pointing at with your mouse scrolled into view. So long as the key is held down
you can manipulate existing notes, moving them around and drawing connections
between them.

B.5 Notes Menu

Provides commands for creating, manipulating and organising notes and shapes within
the active board, or the current selection.

New (Stacked) Note (32Return) When no notes are selected, this will be labelled, “New
Note”, and it will create a note roughly in the middle of the current view.

If a shape is selected, it will act likewise, but the new note will be placed overlapping
the shape.

When a note is selected, this command will create a new stacked note beneath the
selected one. In cases where the selected note is somewhere in the middle of an
existing stack, room will be made for the new note after it, and before the one
following it.

Read Creating Notes (subsection 4.2.1) for more information on how to make new
notes, and Stacks (section 4.5).

New Background Shape (Around Selection) When nothing is selected, this com-
mand will create a new shape roughly in the middle of the view. If anything is
selected (including other shapes), the shape will be pre-sized to fit around the entire
selection, and the menu label will read, “New Background Shape Around Selec-
tion”.

New Connected Note »  This sub-menu provides convenience commands for creating
new notes pre-connected to the currently selected notes. These commands are di-
rectional, and their keyboard shortcuts can be combined with the arrow keys on
your keyboard in a logical fashion. Read more about Connections (section 4.3).

When creating new notes using these commands, they will by default automatically
acquire the style of the initially selected note. In the screenshots depicting the
results of these actions, this effect is not shown, to clarify which note is the “hub”.
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To create this example, the centre note was styled after the new connected notes
were created. This behaviour can be changed in the Preferences (Appendix A).

Basic Connections:

Above

On Left ------- {Initially Selected Note }------ On Right

Below

Figure B.1: New connected notes in the four directions.

The first group of commands create simple dashed connections to the new note
(2?):

4 On Left (~ % LeftArrow)

< On Right (~#RightArrow)

4 Above (™% UpArrow)

4 Below (™ &DownArrow)

The second group of commands will create an arrowed connection pointing to
the new note (2?):

& On Left With Arrow (~ 88 LeftArrow)

¢ On Right With Arrow (~ g RightArrow)

4 Above With Arrow (~ & UpArrow)

4 Below With Arrow (™8 DownArrow)

Connect (82>) Connects two or more selected notes and/or shapes together. The item
selected first will form the “hub” for the connecting lines, when more than two
notes or shapes are selected. If you are looking for a way to connect every selected
note with every other selected note, use Notes » Connect All, below.
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Arrowed Connections:

Above

N\

On Left <«— Initially Selected Note — On Right

/

Below

Figure B.2: New arrowed notes in the four directions.

Connect All Connects each note or shape with every other item in the selection.

Connect With Arrow (Y&.) Connects two or more selected notes and/or shapes to-
gether. The item selected first will be the one which points to the subsequently
selected items. If you are looking for a way to connect multiple notes back to a
single note, it is best to use the mouse to drag a selection of notes onto the target
note, with % held down.

Remove Arrows (\C#2,) Remove all arrows from the selected notes, reverting them to
basic dashed line connections.

Disconnect (38 <) Completely disconnects all selected notes/shapes among each other,
or if only a single item is selected, any lines of connection leading to or from it.

Magnetic (88M) Applicable only the background shapes, this will toggle whether or
not the shape will magnetically carry overlapping notes with it, when the shape is
moved (subsection 4.4.4).

Stack (32°) Applicable to selections of two or more notes. Notes will be stacked in order
of distance (in any direction) from the initial selection. When the initial note is
already in a stack, the other selected notes will be inserted into the stack beneath
that note, moving existing stacked notes down to make space for them.
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Auto-Fit When used on a note, the width of the note will be resized to fit the amount
of text in the note, so that no lines within it are wrapped.

When used on a background shape, the shape will be resized to fit around any

overlapping notes and/or shapes.

Align » Provides tools for tidying up the placement of notes amongst the selection.

The first group will move all notes to match the indicated edge of the note selected
first:

< Left Edges

< Right Edges
< Top Edges

< Bottom Edges

The second group will align notes by the centre of the first-selected note, respec-
tive to the axis chosen:

< Horizontal Centers: draws an imaginary line horizontally through the note
or shape. The items will be moved vertically until their respective lines are all
matching.

< Vertical Centers: likewise, although with the imaginary line drawn vertically
through the note or shape.

Center in Background Shape Applicable only to a single selected note that is
overlapping a shape. The note will be centred both vertically and horizontally
within the shape.

Distribute » Distribute considers the total width or height of the selection, and will
move all of the notes in between the two extreme end notes so that the relative
space between them is equal. Distribution only works on a single axis. Notes will
not be moved vertically, when horizontal distribution is used, and vice versa.

In some cases, if the notes all together have more width than the sum would provide
for in the total width of the selection, overlapping can occur.

Horizontally Distributes the notes evenly along the horizontal axis. No notes
will be displaced up or down on the board.

Vertically Distributes notes evenly along the vertical axis. No notes will be dis-
placed left or right on the board.
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- ™
Before:
One Two Three Four
. J
s ™
After:
One Two Three Four
N J

Figure B.3: The results of using horizontal distribution on four notes.

Make Same Width Adjusts the width of all notes and/or shapes in the selection so that
they all have the same width as the first note selected. This will be done without
moving the notes on the board.

Make Same Height Adjusts the height of shapes and images (not notes, which cannot
be manually resized to be taller than the amount of text they contain) in the same
fashion as resizing them by width, above.

Split (32K) Applicable only when editing text within a note. The note will be split at the
point of the cursor and stacked beneath the current note. If text is selected, only
the selected text will be split into a new note, removing it from the original.

Merge Operates on two or more notes in a selection. They will be merged together in
order of distance from the initially selected note (in any direction), so that all of the
text is displayed in a single note.

Bring Forward (To Front) (\¢8}) When notes or shapes are overlapping one another,
this command will bring the selected items to the top. This and the following
command will make no impact on connection lines. Connections will always be
drawn in a predetermined level—no matter where the items they come from are

displayed.

Send To Back (\“8{) As above, only the selected items will be pushed to the bottom of
the stack.
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B.6 Format Menu

The “Format” menu is used to set the appearance of notes, the text within them, and
shapes. All of the format settings that can be applied to notes can be saved into “Note
Styles”.

Note Style » Note styles provide a way to save select appearance attributes of a note or
shape, and quickly recall them later on selected items on the board. Styles are saved
into each document separately. A few presets will be created into new documents
as practical examples. Read more about Note Style Presets (section 6.3).

New Note Style From Selection Applicable when only a single note or shape
has been selected. This will bring up the “New Style” panel, where you can
choose what aspects of the selected note will be saved into the style for future
use.

Apply Note Style > Operates on all selected notes and/or shapes, applying the
selected style to them. In some cases, this may mean that not all of the style’s
instructions will apply to the selection. For example if a style has been set
to make shapes magnetic, any notes in that selection will ignore that setting.
Likewise text formatting will be ignored by shapes.

This sub-menu is also accessible via the right-click contextual menu.

Delete Note Style » Remove a selected style from the current document. This
will not impact any notes that have had that style applied to them in the past.

Redefine Note Style From Selection» Applicable when only a single note or
shape is selected. The chosen style will be updated with the selected item’s
formatting characteristics. As with deleting styles, this will zor impact notes
that have had this style applied to them in the past.

Copy Note Style (\32C) Applicable when only a single note or shape is selected.
This command (and its sibling command, below) is useful if you wish to du-
plicate formatting between notes or shapes, and do not anticipate needing to
do so repeatedly (saving a note style might be a better choice, in that case).
This command copies all applicable formatting attributes.
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Paste Note Style (\32V) Pastes the currently stored formatting characteristics,
from the Format » Note Style » Copy Note Style menu command, to the se-
lected items.

Import Note Styles... Batch import all of the styles from another Scapple docu-
ment on the disk. This will not overwrite any existing styles in the document.
So if any styles have the same name, you will see duplicate entries, and may
wish to rename them. You can do so by applying the style to a note and then
using the Format » Note Style » Redefine Note Style From Selection sub-menu.

Font » The following commands can be used to style notes, or alternatively, selected
ranges of text within a note. They each work in a toggle fashion. Read more about
Note and Shape Style Options (section 6.2).

< Bold (8B)
4 Tralic (381)

< Underline (8V)
< Strikethrough (Shiftes -)

Bigger (32+) Incrementally increases the text size of the entire note.

To set the precise point size of the text, use The Inspector (chapter 10).

Smaller (32-) Incrementally decreases the text size of the entire note.

Alignment » Alignment impacts the position of text within the note’s total width.
These forms of alignment should be familiar from any word processor. If you are
looking to align the notes themselves amongst one another, use the Notes » Align »
sub-menu.

If the width of the note is precisely as wide as the text content within it, these
commands may not appear to do anything. Experimentally changing the width of
the note should prove they have worked.

< Align Left (389)
4 Center (32 1)
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& Justify (Ce81)
< Align Right (68})

Indents » Indenting adjusts the amount of block padding on the left of the text (or
the right, when typing in right-to-left mode) by a fixed amount. Indenting is often
useful when forming lists of notes in a stack. The overall width of the note will not
be changed by this command, only the formatting of the text within it.

4 Increase Indent Level Tab
4 Decrease Indent Level 4+ Tab

< Remove Indents : Removes all applied indenting from the selected notes.

Colors» The “Colors” sub-menu provides access to the three main characteristics of
notes and shapes that can have their colour changed: text (for notes), borders and

the background fill.

Change Text Color... Will present the standard system colour palette. Any
changes made to the palette will be immediately reflected upon the text of
the selected notes. Ranges of text within a note cannot have their colour
specifically changed.

Clear Text Color Removes any custom colour settings from the text of the se-
lected notes. They will go back to using the document defaults, as set in the
“Document” tab of the Inspector (chapter 10).

Change Fill Color... (1+&C) Applicable to both notes and shapes, the selected
background fill colour will change as colours are set using the system colour
palette. Fill is the default colour type that will be changed if the palette is
called up with the keyboard shortcut.

Clear Fill Color Removes any custom colour settings for the background fill on
selected notes or shapes.

Change Border Color... Applicable to both notes and shapes, the selected
items will have their border colours changed as colours are selected from the
standard system colour palette. If items do not already have a border applied,
the default one pixel border will be added to the note automatically. This is
thus a convenient way to kill two birds with one stone if you wish to apply a
custom border colour to a note that does not already have a border.
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Clear Border Color Removes any custom colour settings for the border colour
on selected notes or shapes.

Borders » Borders can be applied to any note, and shapes by default will have a one
pixel black border. Use this sub-menu to adjust the appearance and width of bor-
ders. To remove a border, select “No Border” from the Format » Borders » sub-
menu. Read more about Applying Borders to Notes & Shapes (subsection 6.2.4).

The contents of this sub-menu can also be accessed from the right-click contextual
menu.

Border widths Choose between five different border widths, or remove the bor-
der by selected “No Border”.

Border styles The second half of this sub-menu provides four different styles of
border that you can choose from (rounded is the default).

Writing Direction »  Users who write in a language that runs from right to left instead
of from left to right can change this for the document here. This will also impact
the auto-resize behaviour of notes (favouring the left side for expansion) and stacks
(the right edge will be need to be flush, instead of the left).

Shadow Add a simple drop-shadow to the selected notes or shapes.

Fade (\#F) Fading notes and shapes will reduce their visual impact on the board, by
causing them to blend into the background colour or texture. When shapes are
faded, any overlapping items will be faded as well, so long as they remain overlap-
ping (they will return to full opacity if dragged out of the faded shape). Read more
about Fading Notes (subsection 6.2.6).

B.7 Window Menu

A “window” refers to the standard container that holds the Scapple board, with the
“traffic lights” along the top-left, document title in the middle, and resize handle on
the bottom-right. This menu concerns itself with the management of these windows
themselves.



B.8. HELP MENU 101

Minimize (M) Reduce the active (topmost) window to an icon in the system Dock.
Simply click on the icon to restore it, or use its named entry from the lower half of
this menu.

Zoom Increases the size of the window to fill all available space, excluding any protected
areas like the main application menu bar, and the system Dock. If you wish to
utilise OS X 10.74+ full screen mode, use View » Enter Full Screen.

Bring All to Front Pushes all Scapple documents to the top of your desktop window
stack, obscuring any open windows from other applications behind them.

Below these stock commands, a list of each open Scapple document will be provided
so that you can easily switch between documents, even if they are not currently visible.
Documents that have been minimised will have a diamond icon to the left of their names.

B.8 Help Menu

Provides access to your Mac’s menu search utility, as well as useful tools and links for
learning Scapple, or getting in touch with us.

The Help menu is the only menu that can be directly activated from the keyboard.
Tap (+88/ to call it up. This will place the cursor in the menu title search field, so you can
begin searching immediately.

Scapple Manual A quick link to the PDF that you are likely reading. The version that
ships with Scapple will be kept as up to date as possible, but newer revisions might
also be available on the web site’s support page’.

QuickStart Guide A handy two-page reference that can be used to quickly learn the
software.

Support A hyperlink to our web site’s support page. Here you can download the latest
copy of the PDF in US Letter or A4 (or the Scrivener project used to make it), find
contact e-mail addresses, links to our forums and wiki, after-sales support from our
vendor, eSellerate, and more.

User Forums Hyperlink to the official Literature & Latte forums where you can meet
other people around the world using Scapple, share tips, report bugs, request tech
support, or have a cup of latte in our off-topic section.

Thttp:/ /www.literatureandlatte.com/support.php


http://www.literatureandlatte.com/support.php
http://www.literatureandlatte.com/support.php
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Literature & Latte Home A handy hyperlink to our home page? which provides easy
access to everything else we offer on our web site.

Scapple Home Link to the main Scapple page’, where you will find useful download
links for updates, tutorials, links to share Scapple on Twitter and Facebook, and

more.

Purchase Scapple... Ready to upgrade from the demo? Use this link to be taken to
our online store. We accept most common forms of payment, and you’ll be sent an
unlock key shortly after payment has been verified electronically. This command
will be removed from any purchased version of Scapple.

Zhttp:/ /www.literatureandlatte.com/
Shttp:/ /www.literatureandlatte.com/scapple.php


http://www.literatureandlatte.com/
http://www.literatureandlatte.com/scapple.php
http://www.literatureandlatte.com/
http://www.literatureandlatte.com/scapple.php

Appendix C

Acknowlegements

This user guide was written in Scrivener and produced with MultiMarkdown and the
IETEX typesetting system.

Much of the “Essentials” part of this user guide is based on the guidance in TextEdit’s
Help file.
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Appendix D

Legal

Scapple and this manual are copyright 2013 by Literature & Latte Ltd. All rights re-
served. Literature & Latte are not affiliated with, or endorsed by the following companies
and their products or services:

4 Microsoft Office; Word, Excel
< Adobe Photoshop

All products above and otherwise mentioned in this text are trademarks of their re-
spective owners.

Literature & Latte take no responsibility for any text lost through synchronisation. As
with all synchronisation processes, you should ensure you back up regularly and double-
check that the right documents are being synchronised.

Visit our web site for a copy of the licence agreement'. By using this software you are
agreeing to be bound by the terms of this licence.

thttp:/ /www.literatureandlatte.com/licence.php
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